[3.5.1] Not honouring "Exclude your visits using a cookie" setting


#1

Matomo 3.5.1 is not honouring the " Exclude your visits using a cookie" option.

When I look at this option under the Personal settings, I’m told that the Exclude cookie was found in my browser (Firefox 60.0.2 on Windows 7 desktop), and that therefore my visits are ignored by Matomo. Unfortunately, this doesn’t work.

I have not yet tried any of the other browsers available to me (IE 11, Opera 54.0, Chrome 67.0, Safari 5.1.7).

I have not enabled any of the Privacy options such as Anonymize IP in Matomo

— Update —
I have tested the other browsers listed above, and can’t reproduce the problem. Firefox has been updated to version 61.0 since the text above was written.

With Firefox, the problem is very intermittent. Sometimes it works, sometimes it doesn’t. In the most recent test, I accessed my site from Tab 2 instead of the usual Tab 1. Matomo reported the access to the home page, but not to any of the subordinate pages. Weird. The second test using Tab 2 worked as expected: Matomo didn’t report any access at all. Likewise for all recent tests using Tab 1.

Accessing the site with Firefox using http instead of https protocol doesn’t seem to make any difference.