[3.5.1] loading of mixed content (matomo.ttf) was blocked?


(Andreas Schnederle-Wagner) #1

Hey there,
getting Error “Laden von gemischten aktiven Inhalten “http://stats.futureweb.at/plugins/Morpheus/fonts/matomo.ttf?gnoj4m” wurde blockiert.” (Loading of mixed Content …/matomo.ttf?gnoj4m was blocked) on https://www.rundblick.at/
Why is it trying to load a font? What’s wrong here?
thx, bye from Austria
Andreas Schnederle-Wagner


(Peterbo) #2

Set in the config:

[General]
force_ssl = 1

Then there will be no mixed content before being redirected.

I’m not 100% sure but I think this is caused by http2 loading (non-ssl) assets before the first request redirects to https.


(Peterbo) #3

That’s a bug of the “shiny” Firefox console when you have more than one open tab and a console error. It is loaded into other threads and repeated.

See 1420680 - Loading woff fonts triggers bogus mixed content warnings in different tab's console (Stylo) and
1427416 - [FF58] Console showing output from other tabs for "blocked mixed-content" when stylo is enabled


(Lukas Winkler) #4

Hi,

That makes a lot of sense. I have been seeing completely unrelated warnings of other tabs for a while in Firefox and always thought something was broken on my setup. (I am using Firefox 60.0.2 on Debian btw)

But I think this means that the error is still occurring (just not on www.rundblick.at, but on your Matomo Dashboard). Can you check this? I’d recommend you to make Matomo only reachable via HTTPS.


(Andreas Schnederle-Wagner) #5

alright - thx for your Answers … changed 2 things:

  1. changed Matomo loading Code in our SAAS CMS to always load from https:// instead of “same protocoll as Website”
  2. added “force_ssl = 1”

Guess that should to the trick and in times of GDPR forced SSL is never wrong I guess … :wink:

thx
Andreas