3.5.0 Installation: Error messages


(Yorh Ekin) #1

Hello,

I get two error messages after installation and upload of the matamo directory to my web server using PHP 7.1


FILE INTEGRITY

Files were found in your Matomo but we didn’t expect them.
–> Please delete these files to prevent errors. <–

File to delete: vendor/maxmind-db/reader/autoload.php

To delete all these files at once, you can run this command:
rm “webserver_root_directory/vendor/maxmind-db/reader/autoload.php”


OTHER FUNCTIONS

shell_exec
You need to enable this built-in function.


What should I do.

Thank you.


(Lukas Winkler) #2

Hi,

You can ignore that warning or simply delete the file. It got left over from the exclusion list.

I think this function is required for many features to work. So maybe ask your host to enable it or try to install it on your own (v)Server instead of an shared hoster. (Which will definitly help performance if you have many visitors)