3.5.0 -> 3.14.1 update database update didn't happen

Trying to update a 3.5.0 version of Matomo to 3.14.1
It didn’t ask me to update the database as it normally does.
Found in the FAQ to do
UPDATE matomo_option SET option_value = "3.5.0" WHERE option_name = "version_core";
But it then told me that there is no table “matomo_option”
What can I do? (I have no shell access).


The name of the table depends on the database prefix you used when installing Matomo. So the table might also be called piwik_option, option or somethingelse_option.

Ok, found the table and executed that SQL Statement without error.
It still doesn’t start database update …
What else can I do?

I’ve now even tried to go back to 3.12.0 …
and it still doesn’t ask for database update!
There MUST be a way, but how?
Is there anything via phpmyAdmin that I can do?
Or was that it with using Matomo?

Is there really nothing I can do to force a database update?

After trying to update 5 instances on different websites - none asked for database updates! I finally found a solution for me.
I’ve renamed the config file, then opened matomo and it began a reinstalaltion. I entered all the same values for the database as before, so it asked if the old database should be used. I agreed. And have a correctly updated matomo now. Cumbersome but worked.
Took me several days to find that possibility.

1 Like