2.7.0 "Sie verwenden die aktuelle Version von Piwik!"


#1

Hallo zusammen,

ich habe zwei Installationen von Piwik (eine dienstlich, eine privat) - die private ist immernoch auf Version 2.7.0, sagt mir aber beim Suchen von Updates, ich würde die aktuelle Version von Piwik nutzen, was nicht stimmt. Die dienstliche habe ich gerade auf 2.8.3 upged … geupda … aktualisiert. Hat jemand eine Idee, woran das liegen könnte?

EDIT: Could some moderator please move this post to the german forum. Thanks a lot!


(Stefan Giehl) #2

Welche PHP Versionen sind auf den Servern im Einsatz?


#3

beides Plesk-Server (eine ne Container-VM und der andere ein Rootserver)
5.3.2-1ubuntu4.27 <-- auf dem geht’s nicht (VM, Ubuntu 10.4 Lucid Lynx)
5.3.10-1ubuntu3.14 <- auf dem geht’s (Ubuntu 12.04 Precise Pangolin)

sollte das minor-release den Unterschied machen?

auf beiden Systemen bekomme ich den Hinweis, dass Php5.3 dem Lebensende entgegen geht und ich werde auch was dagegen unternehmen. Nur geht das auf 'ner Container-VM nicht so mal eben, die Distribution auf den nächsten LTS-release zu hieven.


(Stefan Giehl) #4

Siehe Increase Piwik PHP requirement to PHP 5.3.3 · Issue #6390 · matomo-org/matomo · GitHub


#5

aha … okay, danke. dann muss ich mir jetzt einen Kopf machen, wie ich ein php5.3.3 auf die Maschine bekomme.

Es wäre natürlich schön, wenn die Meldung dann lauten würde: “Für eine neuere Version benötigen Sie mindestens PHP5.3.3”.


(Stefan Giehl) #6

Da muss ich dir recht geben. Du kannst gerne dafür ein Ticket auf GitHub aufmachen. Du bist sicher nicht der einzige Nutzer den soetwas betrifft.
Achja, wenn du schon dabei bist PHP zu aktualisieren solltest du ggf. direkt auf PHP 5.4 aktualisieren… Piwik wird ab etwa Mai PHP 5.4 benötigen. (Announcing Piwik will end PHP 5.3 support in 2016 - Analytics Platform - Matomo)