2.3 - httpd core dumping on loading city row evolution


#1

Hi,

We are on:

Piwik 2.3.0
Linux piwik.gpc.edu. 2.6.32-431.17.1.el6.x86_64 #1 SMP Fri Apr 11 17:27:00 EDT 2014 x86_64 x86_64 x86_64 GNU/Linux
Server version: Apache/2.2.15 (Unix)
Server built: Mar 20 2014 06:21:02
PHP 5.3.3 (cli) (built: Dec 5 2013 07:09:40)
Copyright © 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright © 1998-2010 Zend Technologies

When I load the city row evolution using the free GeoIPCity, the apache child (httpd) core dumps (error_log):

[Wed Jul 09 09:09:07 2014] [notice] child pid 2156 exit signal Segmentation fault (11)

The two access_log entries at the time are:

10.80.8.67 - - [09/Jul/2014:09:08:01 -0400] “POST /piwik/index.php?date=2014-06-10,2014-07-09&module=Live&action=getLastVisitsStart&segment=&idSite=2&period=range HTTP/1.1” 200 365101 “http://piwik.gpc.edu/piwik/index.php?module=CoreHome&action=index&idSite=2&period=range&date=last30” “Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36”

10.80.8.67 - - [09/Jul/2014:09:11:25 -0400] “POST /piwik/index.php?date=2014-06-10,2014-07-09&module=Live&action=getLastVisitsStart&segment=&idSite=2&period=range HTTP/1.1” 200 365101 “http://piwik.gpc.edu/piwik/index.php?module=CoreHome&action=index&idSite=2&period=range&date=last30” “Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36”

This is just a development server that we are testing piwik on right now. The data was build from processing logs, not
using the javascript since we have some questions concerning that (another post).

Any suggestion of where to go from here? I am hesitant about upgrading to 2.4 since I have seen a number of
posting concerning it and I need to review those to make sure there is nothing to worry about. Unless, this is a
known issue and that resolves it.

Thanks,
Douglas


(Matthieu Aubry) #2

see: "Segmentation fault Error". Piwik reporting or via cron crashes with Segmentation Fault error. What to do? - Analytics Platform - Matomo