2.15 Format 24 hours insteand of AM/PM


#1

Hello,

Prior to upgrading to latest version 2.15 i used to have in my real-time live plugin 24 hours format (eg 23:15 instead of 11:15 PM). I live in Europe and i find this am/pm thing just as annoying as inch/feet/yards instead of the billion times much more natural cm/m/km.

How can i revert this, back to 24 hours system? I tried to look in plugin/live/template in visitor.php, controller.php, etc, could not find the solution.

Any help appreciated.


#2

+1 Would like this also :slight_smile:


#3

Update: Looks like now the am/pm or 24 hour mode is dependent on the language (admin tab–> settings, there is the e-mail, password, language).


#4

Just stumbled upon the same issue. Yeah, you have to set up your language in the Personal settings section. By default English uses 12 hour format (AM/PM).


#5

What if I want to use English as default language and 24 hrs as date format?


#6

that is the exact point i made in the ticket created for this issue: Allow switching to 24h format for languages with AM/PM formatted timestamps as default · Issue #9082 · matomo-org/piwik · GitHub

it looks like the guys added the 2.15.1 milestone for this, hence we should have the option to choose the 24/12 hour format regardless of the language in no time.


#7

absolutely agree. I am also interested in this