2.11 upgrade - widget stopped working


#1

Hello, it’s my first problem with Piwik ;o
After using auto-update in web gui and DB upgrade from CLI (as I always do), one of the widget is saying "Zend_Session is currently marked as read-only."
I tried to restart webserver (nginx) and php (php5-fpm), relogging piwik account, using private session in browser but widget just doesn’t work :confused:


#2

Hi! I have exactly the same problem after the update of piwik. Another user in the german forum tested this issue too and it is reproducable.

Kind regards
Jan


#3

Thx for info, I’m not alone then :slight_smile:
I hope that my stats after fix will be consistent.


#4

Hi Piwik Comm!

Im having the same issues after update 2.11.1 :

1. GOALS not working.

“Zend_Session is currently marked as read-only.”

2. Visits Overview (with graph):

An exception has been thrown during the rendering of a template (“Zend_Session is currently marked as read-only.”) in “@VisitsSummary/_sparklines.twig” at line 73.

Any ideas?

Mg


#5

same problem on apache and php54


(Matthieu Aubry) #6

Hi guys,

All of you experiencing this bug, please comment in this issue to make your voice heard!! Goals Overview widget: Zend_Session is currently marked as read-only. · Issue #7274 · matomo-org/piwik · GitHub

Thank you,


#7

Same issue here. Will try to roll back to 2.11.0 for now.


#8

This was posted at github, fixed it for me: https://raw.githubusercontent.com/piwik/piwik/7274/core/Notification/Manager.php


#9

yes, for me too… thx for the link…


#10

Follow github advice! Worked for me!