[2.0.3] Update error: templates_c


(Ivan I.) #1

After the upgrade,the first page of the statistics, get this error.

I tried to delete all the folders in the directory “\tmp\templates_c”, but I have not solved.


There is an error. Please report the message (Piwik 2.0.3) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice:Array to string conversion in C:\inetpub\website.it\statistiche\tmp\templates_c\ac\d6\b5a9521e8e0cc4bfc7eef29e3aa9ea9f556bd282ad729db9d5a61981bddd.php on line 85

Backtrace -->

#0 Piwik\Error::errorHandler(...) called at [C:\inetpub\website.it\statistiche\tmp\templates_c\ac\d6\b5a9521e8e0cc4bfc7eef29e3aa9ea9f556bd282ad729db9d5a61981bddd.php:85]
#1 __TwigTemplate_acd6b5a9521e8e0cc4bfc7eef29e3aa9ea9f556bd282ad729db9d5a61981bddd->doDisplay(...) called at [C:\inetpub\website.it\statistiche\vendor\twig\twig\lib\Twig\Template.php:276]
#2 Twig_Template->displayWithErrorHandling(...) called at [C:\inetpub\website.it\statistiche\vendor\twig\twig\lib\Twig\Template.php:250]
#3 Twig_Template->display(...) called at [C:\inetpub\website.it\statistiche\tmp\templates_c\d4\61\76793e8bea16b2340efb2d40735eeef807473ce68c9ae114be356136259c.php:119]
#4 __TwigTemplate_d46176793e8bea16b2340efb2d40735eeef807473ce68c9ae114be356136259c->doDisplay(...) called at [C:\inetpub\website.it\statistiche\vendor\twig\twig\lib\Twig\Template.php:276]
#5 Twig_Template->displayWithErrorHandling(...) called at [C:\inetpub\website.it\statistiche\vendor\twig\twig\lib\Twig\Template.php:250]
#6 Twig_Template->display(...) called at [C:\inetpub\website.it\statistiche\tmp\templates_c\27\dd\ebe21887c3d90cdd813636b7e11213407c6194f951fe49a465be3f0ea083.php:117]
#7 __TwigTemplate_27ddebe21887c3d90cdd813636b7e11213407c6194f951fe49a465be3f0ea083->doDisplay(...) called at [C:\inetpub\website.it\statistiche\vendor\twig\twig\lib\Twig\Template.php:276]
#8 Twig_Template->displayWithErrorHandling(...) called at [C:\inetpub\website.it\statistiche\vendor\twig\twig\lib\Twig\Template.php:250]
#9 Twig_Template->display(...) called at [C:\inetpub\website.it\statistiche\vendor\twig\twig\lib\Twig\Template.php:261]
#10 Twig_Template->render(...) called at [C:\inetpub\website.it\statistiche\vendor\twig\twig\lib\Twig\Environment.php:292]
#11 Twig_Environment->render(...) called at [C:\inetpub\website.it\statistiche\core\View.php:253]
#12 Piwik\View->renderTwigTemplate(...) called at [C:\inetpub\website.it\statistiche\core\View.php:248]
#13 Piwik\View->render(...) called at [C:\inetpub\website.it\statistiche\core\Plugin\ViewDataTable.php:363]
#14 Piwik\Plugin\ViewDataTable->render(...) called at [C:\inetpub\website.it\statistiche\core\Plugin\Controller.php:230]
#15 Piwik\Plugin\Controller->renderReport(...) called at [C:\inetpub\website.it\statistiche\plugins\Live\Controller.php:96]
#16 Piwik\Plugins\Live\Controller->getLastVisitsDetails(...) called at [C:\inetpub\website.it\statistiche\plugins\Live\Controller.php:104]
#17 Piwik\Plugins\Live\Controller->getVisitorLog(...) called at [:]
#18 call_user_func_array(...) called at [C:\inetpub\website.it\statistiche\core\FrontController.php:117]
#19 Piwik\FrontController->dispatch(...) called at [C:\inetpub\website.it\statistiche\plugins\Goals\Controller.php:113]
#20 Piwik\Plugins\Goals\Controller->getEcommerceLog(...) called at [:]
#21 call_user_func_array(...) called at [C:\inetpub\website.it\statistiche\core\FrontController.php:117]
#22 Piwik\FrontController->dispatch(...) called at [C:\inetpub\website.it\statistiche\index.php:62]



(Ivan I.) #2

No idea?


(Matthieu Aubry) #3

Thanks for the report! please comment in this ticket or check out later, we will fix it asap Notice:Array to string conversion in tmp/templates_c/42/f7/ · Issue #4432 · matomo-org/matomo · GitHub


(Matthieu Aubry) #4

i Have committed a fix, but now that I’m looking closely, I realize your bug is different from the one on: Notice:Array to string conversion in tmp/templates_c/42/f7/ · Issue #4432 · matomo-org/matomo · GitHub

I would need further help to solve this bug:

  1. can you please send a screenshot of the bug ?

  2. andcan you send the file that is mentionned in the bug message. eg. maybe it is still C:\inetpub\website.it\statistiche\tmp\templates_c\ac\d6\b5a9521e8e0cc4bfc7eef29e3aa9ea9f556bd282ad729db9d5a61981bddd

or maybe now it’s a different file so please send me this complete PHP file (or via pastebin.com )


(Ivan I.) #5

Hi matt,
the problem was resolved automatically after a few days! Without touching any files / configuration!