1and1+WP+Piwik+GeoIP PHP : Géolocalisation fausse


#1

Bonjour, je n’ai pas trouvé de réponse ici dans la partie française et si ça a été abordé, merci juste de me dire où.

Mon site Wordpress utilise le plugin WP-Piwik 1.0.14 avec une instance Piwik 3.0.1, le tout hébergé chez 1and1 sur un mutualisé (1&1 Unlimited).
Auparavant tout ça était auto-hébergé et fonctionnait à peu correctement pour Piwik, mais pour des raisons de permanence et de performance, j’ai opté pour ne plus l’auto-héberger et passer chez 1and1.

Là, la Géoloc est “GeoIP (PHP)”, sachant que je ne pense pas pouvoir “monter” à GeoIP (PECL) comme en auto-hébergé précédemment (pas trouvé comment).

En termes d’anonymisation des visiteurs, je suis sur 1 byte et sans IP anonymisée (pour le moment).

Aux erreurs de GeoIPCity.dat près, je devrais avoir une précision de géoloc potable dans la plupart des cas.

C’est pas du tout le cas, par exemple mon @IPv6 est vue aux US, je suis en France…

Your IP Address’s GeoIP2 Data | MaxMind me voit d’ailleurs bien en France avec cette même @IPv6. Ce qui me laisse perplexe puisque Piwik est supposé taper dans les données fournies pas maxmind, non ?

Des pistes ? Merci !


#2

Ho ho, je suis le seul à avoir ce souci ? ou à utiliser Piwik ? ou sur un hébergement 1and1 ?..


#3

Bon, à suivre côté international


(Nicolas Robaux) #4

Salut !
C’est marrant, j’ai quasiment la même configuration que toi (Wordpress en hébergé chez 1&1 mutualisé, sauf que j’ai la formule Wordpress infogéré : c’est eux qui s’occupent de l’installation et mise à jour du core de WP, moi je m’occupe des thèmes et des extensions). J’ai activé un sous-domaine piwik.mondomaine.com, et installé Piwik dans un dossier à côté du dossier WP avec l’extension WP-Piwik, et tout ça marche bien.
Sauf que les adresse IPv6 sont toutes localisées en Chine. Quand je checke cette IPv6 manuellement avec whatismyipaddress.com, ça localise pourtant bien comme Orange/France.
C’est assez perturbant.
Ha non, j’ai encore un truc qui marche pas bien, c’est l’extension Overlay d’analyse des pages web, qui doit générer des petites bulles montrant le nombre de clics : la page et la colonne s’affichent bien, mais la colonne de gauche bloque sur l’affichage “Chargement…”, sans jamais montrer les données. Je ne sais pas trop ce qui se passe.


#5

Je vérifie généralement l’emplacement IP via whatismyip.live car j’ai trouvé leur base de données plus précise que d’autres.