1032 Can't find record in 'log_profiling'


(akkie) #1

Hello,

on my Piwik 0.4.3 installation I get the following error.

array (
  'idsite' => '1',
)

Loading plugins: { Provider}
Detected action normal page view, Action name: index, Action URL =
The visitor is known because he has the piwik cookie (idcookie = 4bbe2900b5495df005a91644f64070f2, idvisit = 7769, last action = Wed, 12 Aug 2009 03:58:28 -0400)
Visit known. Current date is 2009-08-12 03:58:38

array (
  'idSite' => '1',
  'idLinkVisitAction' => '50792',
  'idVisit' => '7769',
  'idRefererAction' => '1',
  'timeSpentRefererAction' => 10,
)

We manage the cookie...
Nothing to notice => default behaviour
End of the page.
Breakdown by query
Executed 2 times in 39ms (average = 19.5ms)

    /* SHARDING_ID_SITE = 1 */INSERT INTO log_action( name, type ) VALUES (?,?)

Executed 1 time in 21.2ms

    /* SHARDING_ID_SITE = 1 */UPDATE log_visit SET visit_exit_idaction = 1,visit_total_actions = visit_total_actions + 1, visit_last_action_time = ?, visit_total_time = UNIX_TIMESTAMP(visit_last_action_time) - UNIX_TIMESTAMP(visit_first_action_time)WHERE idvisit = ? AND visitor_idcookie = ?LIMIT 1

Executed 5 times in 7.8ms (average = 1.6ms)

    /* SHARDING_ID_SITE = 1 */  SELECT idaction FROM log_action  WHERE name = ? AND type = ?

Executed 1 time in 5.9ms

    /* SHARDING_ID_SITE = 1 */ INSERT INTO log_link_visit_action (idvisit, idaction, idaction_ref, time_spent_ref_action) VALUES (?,?,?,?)

Executed 1 time in 4.8ms

    /* SHARDING_ID_SITE = 1 */UPDATE log_visit SET visit_exit_idaction = 16603,visit_total_actions = visit_total_actions + 1, visit_last_action_time = ?, visit_total_time = UNIX_TIMESTAMP(visit_last_action_time) - UNIX_TIMESTAMP(visit_first_action_time)WHERE idvisit = ? AND visitor_idcookie = ?LIMIT 1

Executed 1 time in 3ms

    INSERT INTO log_visit (idsite, visitor_localtime, visitor_idcookie, visitor_returning, visit_first_action_time, visit_last_action_time, visit_server_date, visit_entry_idaction, visit_exit_idaction, visit_total_actions, visit_total_time, visit_goal_converted, referer_type, referer_name, referer_url, referer_keyword, config_md5config, config_os, config_browser_name, config_browser_version, config_resolution, config_pdf, config_flash, config_java, config_director, config_quicktime, config_realplayer, config_windowsmedia, config_gears, config_silverlight, config_cookie, location_ip, location_browser_lang, location_country, location_provider, location_continent) VALUES (?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)

Executed 5 times in 2.9ms (average = 0.6ms)

    connect

Executed 1 time in 0.5ms

     SELECT   visitor_idcookie, UNIX_TIMESTAMP(visit_last_action_time) as visit_last_action_time,UNIX_TIMESTAMP(visit_first_action_time) as visit_first_action_time,idvisit,visit_exit_idaction  FROM log_visit WHERE visit_server_date = ?AND idsite = ?AND config_md5config = ? ORDER BY visit_last_action_time DESC LIMIT 1

Executed 1 time in 0.3ms

    SELECT *, sum_time_ms / count as avg_time_ms  FROM log_profiling


Error query: SQLSTATE[HY000]: General error: 1032 Can't find record in 'log_profiling'
In query: INSERT INTO log_profiling
(query,count,sum_time_ms) VALUES (?,1,3.66)
ON DUPLICATE KEY
UPDATE count=count+1,sum_time_ms=sum_time_ms+3.66
Parameters: array (
0 => '/* SHARDING_ID_SITE = 1 */
UPDATE log_visit
SET visit_exit_idaction = 1,
visit_total_actions = visit_total_actions + 1,

visit_last_action_time = ?,
visit_total_time = UNIX_TIMESTAMP(visit_last_action_time) - UNIX_TIMESTAMP(visit_first_action_time)
WHERE idvisit = ?
AND visitor_idcookie = ?
LIMIT 1',
)

Greetings,
Akkie