Zend_Session is currently marked as read-only after hdd drive was full


#1

Hi,

due to the problem that the archiving is not working and DB-size grows every archiving run my hdd was completely full.

Now I cannot run the archiving anymore. Zend_Session is currently marked as read-only.

Folder tmp\sessions was not there, i have now created. also the user have full rights on this folders. The WebGUI works without problems.

any recommondations?


(vipsoft) #2

bulk loading is coming in 1.3. in the meantime, try increasing your memory_limit.


#3

thx for answer, i have memory_limit already at 256 MB, my DB is currently 944 KB in size (i deleted the archive to get free space and want to build the archives with fresh copy).

The error message “Zend_Session is currently marked as read-only” maybe then says there is already a session (but not in tmp\sessions - thats empty) but I don’t know.


(vipsoft) #4

It sounds like the problem is a lack of free space in /tmp which is used by (default) by PHP and MySQL for temporary files.

For PHP, look at the session.save_path in /etc/php/php.ini (or similar).
For MySQL, look at the tmpdir setting in /etc/mysql/my.cnf.

For Piwik to use the local tmp/sessions folder that you created, you have to tell Piwik to ignore the master php.ini setting. You can create an .htaccess file to set the session.save_path, or use a bootstrap.php file in your piwik folder, e.g.,


<?php
ini_set('session.save_path', dirname(__FILE__).'/tmp/sessions);


#5

I had to amend the script file that was executing (archive.windows.ps1) -changed the top line:

#$PHP_INI = “C:\Program Files\EasyPHP-5.3.2i\apache\php.ini”

to

$PHP_INI = “C:\Program Files\PHP\php.ini”

and it’s all working a treat.