Zend location during installation


(carloscm) #1

Hello everyone,

apparently putting the files online over FTP, CHMODing everything to 777 and going to http://www.whereever.com/piwik isn’t good enough, as I get

Warning: require_once(Zend/Registry.php) [function.require-once]: failed to open stream: No such file or directory in /srv/www/htdocs/web68/html/piwik/core/ErrorHandler.php on line 12

Fatal error: require_once() [function.require]: Failed opening required ‘Zend/Registry.php’ (include_path=’.’) in /srv/www/htdocs/web68/html/piwik/core/ErrorHandler.php on line 12

This happens on one of my webspaces but not on the other. Is “safe mode” the reason, as far as I can see the only major difference between both hosters?

If I change that line in ErrorHandler.php from “Zend/Registry.php” to “libs/Zend/Registry.php” this error goes away, but a similar error appears in another file… and another… and another. I quit after around 20 file edits.


(michaelc) #2

Hi carloscm,

Welcome to the Piwik community forums!

For more information regarding your problem please refer to this FAQ entry: http://piwik.org/faq/troubleshooting/#faq_44


(tapper) #3

[quote=carloscm @ Dec 14 2008, 01:28 AM]Hello everyone,

apparently putting the files online over FTP, CHMODing everything to 777 and going to http://www.whereever.com/piwik isn’t good enough, as I get

Warning: require_once(Zend/Registry.php) [function.require-once]: failed to open stream:[/quote]
I’m getting the same error. I’ve FTP’ed several times, into a zen cart site and into a static site. Both will not load the start page. Also, my host doesn’t allow CHMOD of 777, 755 is as high as we can go. Will this run if the permissions are only 755?

Warning: require_once(Zend/Db/Table/Abstract.php) [function.require-once]: failed to open stream: No such file or directory in …/piwik/libs/Zend/Db/Table.php on line 25
[I’ve replaced my path with … in the errs below]

Fatal error: require_once() [function.require]: Failed opening required ‘Zend/Db/Table/Abstract.php’ (include_path=’…/piwik:…/piwik/libs/:…/piwik/plugins/:…/piwik/core/:.:/usr/lib/php:/usr/local/lib/php’) in …/piwik/libs/Zend/Db/Table.php on line 25


(tapper) #4

Fixed

I switched to FileZilla and tried uploading again. Setup is running fine now


(batman1983) #5

I’m getting the same error. I’m using piwik 0.4.2. I tried Filezilla and Cyberduck (both MacOSX).
Perhaps somebody can check it: http://bk83.de/
FYI phpinfo: http://bk83.de/phpinfo.php


(vipsoft) #6

[quote=batman1983 @ Jul 24 2009, 03:12 PM]I’m getting the same error. I’m using piwik 0.4.2. I tried Filezilla and Cyberduck (both MacOSX).
Perhaps somebody can check it: http://bk83.de/
FYI phpinfo: http://bk83.de/phpinfo.php[/quote]
That’s because you have a local include path override that prevents Piwik from changing the include path. (Look in your .htaccess or local php.ini.)