Your database supports utf8mb4 charset, but your database tables have not been converted yet

In matomo there is the error message:

Your database supports utf8mb4 charset, but your database tables have not been converted yet. You can do this by executing the command /home/justkeepmoving/public_html/wp-content/plugins/matomo/app/console core:convert-to-utf8mb4 or activating the automatic conversion in General Settings.

I cannot see anything about conversion in general settings and have no idea how to execute a command. can someone give me information for either / both. Thanks


In order to execute a command in Matom, you need to have access to your server using SSH.
If you have apache2 on your server (software that runs websites), you have to move to your /var/www folder and run the command using PHP CLI (PHP for command lines).

This could be a little tricky if you never connect a server thru SSH


ive never connected via ssh. Im looking in cpanel and it looks like an ftp kinda thing. Thanks for the info, but as I really know nothing about this, it this could take me all night to set up and work through.

Anyone have any ideas regarding activating the automatic conversion in General Settings?? I cant see it in there. What am I missing?

FTP will no allow you to run commands, only SSH can help you.

You can’t activate this in General Settings, this is a large configuration in your database, not an “togglable” option.

In CPanel, you can create and get credentials for SSH connection.
If you are on Mac, you can use the default terminal to connect.
If you are on PC, you have to install GIT SCM and run Git bash terminal.

To connect to SSH you have to open a terminal and run :
ssh username@123.456.789.10
Terminal will ask for SSH key or password

Then move to your Matomo installation folder (probably in /var/www/matomo)
You can move into a folder using command cd <folder name>
You can go backward using cd ..
You can explore current directory using ls

Once you are in the matomo directory, yu just have to run : php console core:convert-to-utf8mb4
This command may take several minutes to run depending on your database size

Then you can close your terminal and enjoy the changes.


Thank you for the very detailed instructions. Much appreciated. Ill give it a try. In the error message it does say that it can be activated in general settings (I copy and pasted), so thats why I put that there and was a little confused, but all good, ill try the instructions.

I have several websites and don’t recall seeing this error on other ones. I would have thought they would all have it. Ill have to go through and check them.

Thanks for your help