X-Forwarded-For is not used after update from 2.10 to 2.11


#1

We’re behind a load balancer and have our config.ini.php configured:
proxy_client_headers[] = "HTTP_X_FORWARDED_FOR"
proxy_host_headers[] = “HTTP_X_FORWARDED_HOST”

Prior to updating to 2.11, we were getting correct client IPs, but now everything has load balancer IPs.
Our configuration didn’t change.

Is there a workaround / patch for this bug?


#2

Also running behind a load balancer, had that issue updating to 2.10 (proxy_client_headers[] & proxy_host_headers[] settings removed from config), but added them back manually.

Have just updated to 2.11 and those proxy settings were carried forward in the config and everything’s working as normal in regards to correct IP.

Are the settings still in config.ini.php? Do you need to adjust those piwik proxy settings for your particular load balancer/reverse proxy setup? (theres a few recommendations for different proxy setups).


#3

I was looking at the wrong config file (an old copy) – I think you’re right about the update removing the proxy_client_headers[] & proxy_host_headers[] settings.
I added them back into the proper config file and it seems to be working fine, now.

Thanks