Widgets won't save


#1

For some reason when I add a widget to the dashboard it won’t save it, what am I doing wrong?


#2

please describe procedure on how you try to save tehm on dashboard


#3

I don’t save it at all, I thought it should auto save the layout, if I add a widget and move to another page I get an error saying something like opps can’t do that.


#4

ok i think i have a better idea, Could you make a screen grab of the error. I wondered also could you try and use a different browser?


#5

The error I get when saving settings is Oops… problem during the request, please try again
The only way I can edit things like exclude IP’s is directly in the DB, I’ve tried different browsers and I’ve also installed a new copy in another directory, with a new DB still the same


#6

Also if I add a goal for example paypal/review the / get’s changed to %20 same with spaces in the name of the goal


#7

Have you contacted Admin?


#8

I am the only user


#9

Ok this could be memory related. Have you upped the memory limit in your php.ini? if your are at 126 try bumping up to 256 etc…

Also a cronjob could help. If you have a site thats been running for a while this would help memory issues.

http://piwik.org/setup-auto-archiving/


#10

In my php.ini it says memory_limit = 256M in my .htaccess it’s php_value memory_limit 512M

What do I need a cron job to do?


#11

See teh link in my post

Linux/Unix: How to Set up a Crontab to Automatically Archive the Reports.

I thinking the reports may need to be archived so they do not consume so much memeory.


#12

There are no reports to archive as I’ve done a clean install of it, twice now.


#13

Hmmmm om lets start from teh base…

How did you upload the install files? What is your server stats as far as OS etc…?


#14

I’ve uploaded them using FTP and also used wget in SSH, I’m using CentOS and have the following installed, the server is dedicated with 8GB of ram

[PHP Modules]
bz2
calendar
Core
ctype
curl
date
dom
eAccelerator
ereg
exif
fileinfo
filter
ftp
gd
gettext
gmp
hash
iconv
imap
ionCube Loader
json
libxml
mbstring
mcrypt
mhash
mysql
mysqli
openssl
pcntl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
readline
Reflection
session
shmop
SimpleXML
sockets
SPL
standard
tokenizer
wddx
xml
xmlreader
xmlrpc
xmlwriter
xsl
zip
zlib

[Zend Modules]
eAccelerator
the ionCube PHP Loader

PHP 5.3.8 (cli) (built: Oct 31 2011 18:26:52)
Copyright © 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright © 1998-2011 Zend Technologies
with eAccelerator v0.9.6-svn358-dev, Copyright © 2004-2007 eAccelerator, by eAccelerator
with the ionCube PHP Loader v4.0.7, Copyright © 2002-2011, by ionCube Ltd.


#15

ok Im also using cent OS with no problems. but I have a lower version of apache php. Did you recently update to run the newer 5.3 php extension?

From a memory aspect can you check teh memory allocated to php perhaps that needs to be bumped up?


#16

I haven’t updated php for a while, I’ve just upped the memory limit to 512 and thats not helped


#17

ok just relooking at your screen grab to clarify, that is a website on website management, the error of a widget you mentioned earlier can you put a screen grab of that? I just want to clarify is it in dashboard or web site maangement or both you get anerror?


#18

There is nothing to see on the screen, I move the widgets or add new ones when I go back to the page the are all back to default, but sometimes I see the message Oops… problem during the request, please try again


#19

Can you find anything in the various apache logs that could help?


#20

I don’t really know what I’m looking for or in which but I can’t see anything obvious