Widget format


(sebigbos) #1

Hello,

the columns of the widgets displayed (using firefox 4) are to big. I can only see the first column (for example in the widget “pages” ) . Even if I use the “enlarge”-Button not all the columns are visible.

I tried to use a smaller font using this code

.widget {
font-size:9px !important;
}

in themes/default/common.css. This works, but the headers in the columns are still large so it does no effekt. I also tried to substitute the long header “Seitenansichten” in the lang/de.php with something shorter, but this gives an error message.
Any idea?
sebigbos


#2

You could add


table.dataTable th {
    font-size: 9px !important;
}

to common.css to change the font-size of table headers.


(sebigbos) #3

Hi n0v1,

thanks for your suggestion. I tried this but it doesn´t work.

s.


#4

It should work after deleting tmp/assets and tmp/templates_c.


(sebigbos) #5

That´s it, it works now, thanks. But even with 9px the german headers are very long, so I still cannot see all columns of the widget. Trying to change the header in the lang/de.php gives the following error code:

[size=small]Warning: Cannot modify header information - headers already sent by (output started at /is/htdocs/wp1048605_MQK2HRK8IN/www/piwik/lang/de.php:1) in /is/htdocs/wp1048605_MQK2HRK8IN/www/piwik/core/Controller.php on line 447

Backtrace -->
#0 Piwik_ErrorHandler(2, Cannot modify header information - headers already sent by (output started at /is/htdocs/wp1048605_MQK2HRK8IN/www/piwik/lang/de.php:1), /is/htdocs/wp1048605_MQK2HRK8IN/www/piwik/core/Controller.php, 447, Array ([moduleToRedirect] => CoreHome,[actionToRedirect] => index,[websiteId] => 1,[defaultPeriod] => day,[defaultDate] => yesterday,[url] => Location: index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday)) called at [(null):0]#1 header(Location: index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday) called at [/is/htdocs/wp1048605_MQK2HRK8IN/www/piwik/core/Controller.php:447]#2 Piwik_Controller->redirectToIndex(CoreHome, index, ) called at [/is/htdocs/wp1048605_MQK2HRK8IN/www/piwik/plugins/CoreHome/Controller.php:42]#3 Piwik_CoreHome_Controller->redirectToCoreHomeIndex() called at [(null):0]#4 call_user_func_array(Array ([0] => Piwik_CoreHome_Controller Object ([] => CoreHome,[] => ,[] => ,[] => 0,[] => Piwik_Site Object ([] => 0)),[1] => redirectToCoreHomeIndex), Array ()) called at [/is/htdocs/wp1048605_MQK2HRK8IN/www/piwik/core/FrontController.php:127]#5 Piwik_FrontController->dispatch() called at [/is/htdocs/wp1048605_MQK2HRK8IN/www/piwik/index.php:58][/size]

Any idea?


#6

I tried changing the german headers and it worked. Did you perhaps accidentally change the encoding of the file while modifying it? Should be UTF-8.


(sebigbos) #7

I don´t think so but I´m not sure. I use the default editor included in filezilla to edit phps. I tried now another editor with the option utf-8 to choose when saving. But´s the same error code


#8

Could you please paste the contents of your modified de.php to http://pastebin.com/ or a similar service so that I can have a look at it / try it myself. Thanks.


(sebigbos) #9

You can get the de.php here:

server-Name: ftp://musikunterricht-in-rosenheim.de/
username: ftp1048605-web
pw: someotherblues


#10

The problem lies within the encoding of the file. Your modified file is encoded as UTF8 with BOM whereas it should be UTF8 without BOM. See Byte order mark - Wikipedia. A minor difference but enough to let Piwik stumble. If you have to modify files locally I suggest using Notepad++ which preserves the encoding / is able to convert files to different encodings. After converting your file to UTF8 without BOM the modified headers were displayed correctly.


(sebigbos) #11

wow, that´s it. And besides the new editor is much better than the windows stuff.

Thanks a lot!
sebigbos