Why doesn't matomo works? [here is a report..]

				  # Matomo

* Matomo Plugin Version: 4.15.3
* Config exists and is writable.: Yes ("$abs_path/wp-content/uploads/matomo/config/config.ini.php" )
* JS Tracker exists and is writable.: Yes ("$abs_path/wp-content/uploads/matomo/matomo.js" )
* Plugin directories: Yes ([{"pluginsPathAbsolute":"$abs_path\/wp-content\/plugins\/matomo\/plugins","webrootDirRelativeToMatomo":"..\/"}])
* Tmp directory writable: Yes ($abs_path/wp-content/cache/matomo)
* Matomo Version: 4.15.1
* Matomo Blog idSite: 1
* Matomo Install Version: 4.15.3 (Install date: 2024-01-26 21:22:00)
* Upgrades outstanding: No
* Upgrade in progress: No

## Endpoints

* Matomo JavaScript Tracker URL:  ($site_url/wp-content/uploads/matomo/matomo.js)
* Matomo JavaScript Tracker - WP Rest API:  ($site_url/wp-json/matomo/v1/hit/)
* Matomo HTTP Tracking API:  ($site_url/wp-content/plugins/matomo/app/matomo.php)
* Matomo HTTP Tracking API - WP Rest API:  ($site_url/wp-json/matomo/v1/hit/)

## Crons

* Server time: 2024-01-26 19:25:58
* Blog time: 2024-01-26 21:25:58 (Below dates are shown in blog timezone)
* Sync users & sites: Next run: 2024-01-27 21:23:16 (23 שעות ו-57 דקות) ( Last started: 2024-01-26 21:23:16 (-2 דקות ו-42 שניות). Last ended: 2024-01-26 21:23:16 (-2 דקות ו-42 שניות). Interval: daily)
* Archive: Next run: 2024-01-26 22:22:01 (56 דקות ו-3 שניות) ( Last started: 2024-01-26 21:22:01 (-3 דקות ו-57 שניות). Last ended: 2024-01-26 21:22:02 (-3 דקות ו-56 שניות). Interval: hourly)
* Update GeoIP DB: Next run: 2024-02-25 21:23:16 (29 ימים ו-23 שעות) ( Last started: 2024-01-26 21:23:16 (-2 דקות ו-42 שניות). Last ended: 2024-01-26 21:23:22 (-2 דקות ו-36 שניות). Interval: matomo_monthly)

## Mandatory checks

* גרסת PHP >= 7.2.5: ok 
* PDO הרחבה: ok 
* PDO\MYSQL הרחבה: ok 
* MYSQLI הרחבה: ok 
* Other required extensions: ok 
* Required functions: ok 
* Required PHP configuration (php.ini): ok 
* Directories with write access: ok 
* Directories with write access for Tag Manager: ok 

## Optional checks

* 64-bit PHP Binary: ok 
* Tracker status: ok 
* Memory limit: ok 
* אזור זמן: ok 
* Open URL: ok 
* GD > 2.x + FreeType (graphics): ok 
* Other extensions: ok 
* Other functions: ok 
* Filesystem: ok 
* Last Successful Archiving Completion: ok 
* Database abilities: ok 
* Max Packet Size: ok 
* מיקום גאוגרפי: ok 
* Update over HTTPS: ok 
* Supports Async Archiving: Yes
* Async Archiving Disabled in Setting: No
* Location provider ID: geoip2php
* Location provider available: Yes
* Location provider working: Yes
* Matomo URL: Yes ($site_url/wp-content/plugins/matomo/app)

## Matomo Settings

* Track mode: default
* Track ecommerce: Yes
* Track codeposition: footer
* Track api endpoint: default
* Track js endpoint: default
* Version history: 4.15.3
* Core version: 4.15.1
* Last tracking settings update: 1706296988
* Last settings update: 1706296988

## Logs

* None: 

# WordPress

* Home URL: $site_url
* Site URL: $site_url
* WordPress Version: 6.4.2
* Number of blogs: 1
* Multisite Enabled: No
* Network Enabled: No
* WP_DEBUG: No
* WP_DEBUG_DISPLAY: Yes
* WP_DEBUG_LOG: No
* DISABLE_WP_CRON: -
* FORCE_SSL_ADMIN: Yes
* WP_CACHE: Yes
* CONCATENATE_SCRIPTS: -
* COMPRESS_SCRIPTS: -
* COMPRESS_CSS: -
* ENFORCE_GZIP: -
* WP_LOCAL_DEV: -
* WP_CONTENT_URL: $site_url/wp-content
* WP_CONTENT_DIR: $abs_path/wp-content
* UPLOADS: -
* BLOGUPLOADDIR: -
* DIEONDBERROR: -
* WPLANG: -
* ALTERNATE_WP_CRON: -
* WP_CRON_LOCK_TIMEOUT: 60
* WP_DISABLE_FATAL_ERROR_HANDLER: -
* MATOMO_SUPPORT_ASYNC_ARCHIVING: -
* MATOMO_ENABLE_TAG_MANAGER: -
* MATOMO_SUPPRESS_DB_ERRORS: -
* MATOMO_ENABLE_AUTO_UPGRADE: -
* MATOMO_DEBUG: -
* MATOMO_SAFE_MODE: -
* MATOMO_GLOBAL_UPLOAD_DIR: -
* MATOMO_LOGIN_REDIRECT: -
* Permalink Structure: /%postname%/
* Possibly uses symlink: No
* Upload base url: $site_url/wp-content/uploads
* Upload base dir: $abs_path/wp-content/uploads
* Upload url: $site_url/wp-content/uploads/2024/01
* Custom upload_path: 
* Custom upload_url_path: 
* Compatible content directory: Yes

# WordPress Plugins

* Elementor: 3.18.3
* Elementor Pro: 3.18.3
* LiteSpeed Cache: 6.0.0.1
* Matomo Analytics - Ethical Stats. Powerful Insights.: 4.15.3
* miniOrange 2 Factor Authentication: 5.8.1
* One Click Accessibility: 2.1.0
* Under Construction: 3.97
* UpdraftPlus - Backup/Restore: 1.23.16
* Active Plugins: 7 (elementor-pro:3.18.3 elementor:3.18.3 litespeed-cache:6.0.0.1 matomo:4.15.3 miniorange-2-factor-authentication:5.8.1 pojo-accessibility:2.1.0 updraftplus:1.23.16)
* Theme: hello-elementor (hello-elementor)

# Server

* Server Info: LiteSpeed
* PHP OS: Linux
* PHP Version: 8.1.27
* PHP SAPI: litespeed
* PHP Binary Name: /usr/local/bin/lsphp
* PHP Maxmind DB extension: Not loaded
* PHP Error Reporting: 4437 After bootstrap: 4437
* PHP Found Binary: /opt/cpanel/ea-php81/root/usr/bin/php -q
* Timezone: UTC
* WP timezone: Asia/Jerusalem
* Locale: he_IL
* User Locale: he_IL
* Memory Limit: 512M (At least 128MB recommended. Depending on your traffic 256MB or more may be needed.)
* WP Memory Limit: 40M
* WP Max Memory Limit: 512M
* Timezone version: 0.system
* Time: 1706297158
* Max Execution Time: 30
* Max Post Size: 256M
* Max Upload Size: 134217728
* Max Input Vars: 1000
* Disabled PHP functions: No
* zlib.output_compression is off: Yes
* Curl Version: 7.61.1, OpenSSL/1.1.1k
* Suhosin installed: No

# PHP cli

* PHP cli Version: 8.1.27
* MySQLi support: ok

# Database

* MySQL Version: 10.6.16
* Mysqli Connect: Yes
* Force MySQL over Mysqli: No
* DB Prefix: wpl4_
* DB CHARSET: utf8mb4
* DB COLLATE: 
* SHOW ERRORS: No
* SUPPRESS ERRORS: No
* Uses Socket: No
* Uses IPv6: No
* Matomo tables found: 47
* DB tables exist: Yes
* Matomo users found: 1
* Matomo sites found: 1
* Required permissions: OK

# Browser

* Browser:  (Mozilla/5.0 (X11; Linux x86_64; rv:122.0) Gecko/20100101 Firefox/122.0)
* Language: en-us,en

	

thank you

Hi @100-SONGS

Why doesn’t matomo works?

But what are the symptoms of “not working”?

the visitors are not shown

Hi @100-SONGS
Sorry for the time of response.
can you check if there is HTTP requests from your tracked page to your Matomo server? (check in the network tab of the browser developer tool)