What matomo version does the Heatmaps work with?

I was about to update Matomo to 4.2.1, but got a message that the Heatmaps will not work, but require Matomo < 4.0.x. Is this correct? The Heatmaps FAQ only state that the Matomo version should me later than 3.something. When do we get heatmaps that work with the latest version oh Matomo?




You can see the requirements for Heatmap on https://plugins.matomo.org/HeatmapSessionRecording

The version 4.0.11 of the plugin (the latest at the moment) requires Matomo >=4.0.0-b5,<5.0.0-b1.

You are probably using version 3.2.39 of the plugin which supports Matomo >=3.0.4-rc1,<4.0.0-b1.

This message is correct, but possibily a bit misleading. The version of Heatmaps you have currently installed, doesn’t support Matomo 4. But there is a newer version of Heatmaps that only supports Matomo 4 and during the update to Matomo 4, Matomo downloads this version and you can continue to use it just like before.

Ok, so I need to update both Matomo and the Heatmap plugin. Is that the preferred way (update Matomo and let it uninstall the plugin, then re-install a newer version of the plugin)?


If you normally update Matomo, then the plugin will be automatically updated at the same time.

If your Matomo server has no access to the internet and you replace the files manually, you can just replace the plugin after you updated.

Ah, ok. The installation page read (or at least I interpreted the text such as) when a Matomo version >4.0.x is installed, then the installer will automatically uninstall the heatmaps. Good thing that the heatmaps plugin will be updated, not uninstalled.