Weekly Email Reports: end of the month bug?


#1

We have some 700 client sites in Piwik, all of which are configured for monthly and weekly reports. We’ve noticed the past few months that the second to last weekly report isn’t sent until the turn of the new month. So for example:

Weekly report for Nov 18-24 was sent on Dec 1
Weekly report for Nov 25 – Dec 1 was sent on Dec 2 as it should have been.

Why isn’t the report for Nov 18-24 sent on Nov 25? This seems like a bug to me because I can’t imagine a scenario in which someone would want their second to last weekly report of the month delayed a week.

System Info: We’re on Piwik 1.12 and there are no errors in the archive.php log or in the httpd log.


(Matthieu Aubry) #2

can you please try with the Piwik 2.0 from : 301 Moved Permanently

The latest beta works very well and I think this bug will be fixed!


#3

Upgrading to a beta of a version described as a major upgrade isn’t an option for serious users like us with hundreds of client websites dependent upon Piwik. I already see problems with the upgrade process being posted, and it would be hours and hours of work for us just to test a beta that may or may not address this issue.

Do you have any concrete knowledge about this issue and any temporary fixes that could help? 800 clients getting double reports on the first of the month is a big inconvenience.


(Matthieu Aubry) #4

Really the latest beta 12 is super safe and stable. Just keep copy of the database so you can revert if any problem.


#5

With the latest 2.0 version is it not possible to store the definitions of a report. If I open an existing report, all selections are empty. After changing, saving, reopening - the selection is still empty. Also created a new report - same result.


(Matthieu Aubry) #6

[quote=RightVision]
With the latest 2.0 version is it not possible to store the definitions of a report. If I open an existing report, all selections are empty. After changing, saving, reopening - the selection is still empty. Also created a new report - same result.[/quote]

Thanks for the report, created a ticket at Editing a Scheduled report in Morpheus · Issue #4393 · matomo-org/matomo · GitHub will fix asap!