Website long time get matomo file

My website long time downloads matomo file. Problem is only with matomo,but not with other files. Where I can looking resolve?
Speed loading is very important for Google SEO.


How solve it?

How solve this problem?

How does the Matomo admin interface perform?
Which version of Matomo do you use?
Are these requests POSTs or GETs?
On which browser did you try?

  1. How does the Matomo admin interface perform?
    Could you explain it exactly?
  2. Which version of Matomo do you use?
    4.6.2
  3. Are these requests POSTs or GETs?
    In screenshot is request with “idsite”. In logs server it’s GET requests
  4. On which browser did you try?
    it’s not matter

When you access the Matomo UI (in order to configure Matomo measurables, etc), is it fast or slow?

Also, in the HTTP console of your browser, can you check the response of the requests that are slow?

I selected long time loading:
Dashboard


Settings

How soilve this problem?

Then your Matomo administration interface is very slow…
Does me Matomo server have an access to the Internet? (eg can the Matomo server access the Marketplace, the list of available updates, etc.)
If not (for example because of some firewall rules), then this can lead to some slowness…
https://matomo.org/faq/troubleshooting/faq_16646/

Other possible reasons:
https://matomo.org/faq/troubleshooting/faq_140/

No, it’s normal hosting.
In settings, are only 3 websites

How busy is your Matomo server? How many hits (any kind hit: page view, events, goals, etc.) per day do you track? How busy is your database? Is the database hosted on another server?

What’s it mean? It’s shared hosting

several hundred,per day

I don’t know. It’s shared hosting. Everything is together

Do you have access to server usage at your provider? (CPU, data transfer, nb of requests, etc.)
Try maybe to disable Internet features (in the Matomo config file: section [General], key enable_internet_features, set value to 0)

No result. I gave default tracking code.

This should not be the case…
You may ask your provider if it sees some problem somewhere. Or maybe some kind of “DDOS attack firewall” delays the request?

Support is not helpful:

We have verified your resource use and you do not have any excesses, so your hosting service is working properly. Unfortunately, we do not have a PHP programmer in our company, so it is difficult for us to say something. Most likely you would have to track the execution of the scripts in the matomo.php file. I would like to add that updating the website / software to PHP 8.0 would certainly speed up the execution of scripts and the page loading time would decrease.

Is it possible for you to try (one of):

  • Install and enable QueuedTracking plugin?
  • Migrate PHP to V8?
  • Migrate to one of the latest Matomo version?

It’s little better. I enabled and set Redis


But sometimes is long time again.
I migrate to latest Matomo version and Install and enable plugin. Nowadays I has Matomo in subcatalog my website with PHP.7,4.
I will move Matomo to subdomain and change PHP to 8.
Joomla must using PHP 8 or only Matomo?

Very strange…
You may enable Matomo debut in order to see where time is spent:
https://developer.matomo.org/guides/tagmanager/debugging

Temporary I removed piwik code. Googlebot had problem with mobile friendly.I will come back future.