Web-cron fails after Update to 2.14


#1

We updated piwik on friday and since then our web-cron fails.

This is what is returned for every website logged with piwik:

ERROR CoreAdminHome[2015-07-13 09:21:02] [eb8b0] Empty or invalid response ‘’ for website id 1, Time elapsed: 0.163s, skipping INFO CoreAdminHome[2015-07-13 09:21:02] [eb8b0] Will pre-process for website id = 3, period = day, date = last52 INFO CoreAdminHome[2015-07-13 09:21:02] [eb8b0] - pre-processing all visits ERROR CoreAdminHome[2015-07-13 09:21:02] [eb8b0] Got invalid response from API request: ?module=API&method=API.get&idSite=3&period=day&date=last52&format=php&trigger=archivephp. Response was '
Forbidden

You don’t have permission to access /misc/cron/ on this server.

Has anyone else experienced this problem?
And maybe has a solution?

I assume, piwik makes a direct call to /misc/cron/?module=API&method=API.get&idSite=6&period=day&date=last52&format=php&trigger=archivephp[…] instead /?module=API&method=API.get&idSite=6&period=day&date=last52&format=php&trigger=archivephp, but I’m not sure about this


(Matthieu Aubry) #2

Hello,

This bug was fixed in 2.14.1-b1 - it will be released in coming 2 weeks but you can already update to enjoy this fix: I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo


#3

Not sure if it’s related, but I just installed Piwik yesterday and I’m getting a similar error with version 2.14.1. The error message is:

Error: Empty or invalid response ’ 403 Forbidden

Forbidden

You don’t have permission to access /piwik/ on this server.

’ for website id 1, Time elapsed: 0.155s, skipping