Warning message on new installation


I have just installed and configured Matomo on-prem. However, i get the message below on the settings page - is anyone able to assist please?

WARNING: C:\inetpub\wwwroot\matomo\core\Http.php(539): Warning - Trying to access array offset on value of type null - Matomo 4.0.1 - Please report this message in the Matomo forums: https://forum.matomo.org (please do a search first as it might have been reported already) (Module: Installation, Action: systemCheckPage, In CLI mode: false)

Many Thanks,


This is the same as

For whatever reason, when Matomo tries to make a HTTP request (e.g. to fetch data from the marketplace), it gets back an empty response.
Matomo then tries to display an error message with the last error that occured, but there is no error (which causes the warning you see).

You can try to install php-curl as then Matomo uses that instead of the fopen-based method and it circumvents this issue. Or you could try to find out why your server can’t do HTTP requests in PHP.

Hi, thanks for your response. I have enabled PHP Curl and that message has disappeared.

I do however have an issue trying to install the google analytics plugin as i get this server error either trying to access the marketplace or import a zip file. Any ideas on that one? From what I read in the other article, it seems the issues may have been related?

( 500 - Internal server error. ### There is a problem with the resource you are looking for, and it cannot be displayed.)

Many thanks


I’d recommend you to look into your PHP error log or Matomo log to see the exact error that is happening.

Thanks, I increased the logging detail and it says the below when trying to upload the ZIP file. I am entering the Super User password when it asks for one.

ERROR Piwik\ExceptionHandler[2020-12-01 11:04:09 UTC] [ffda2] Uncaught exception: C:\inetpub\wwwroot\matomo\core\Common.php(535): The parameter ‘confirmPassword’ isn’t set in the Request, and a default value wasn’t provided.
ERROR Piwik\ExceptionHandler[2020-12-01 11:04:09 UTC] [ffda2] The parameter ‘confirmPassword’ isn’t set in the Request, and a default value wasn’t provided.


This sounds a bit like a bug and I created an issue here:

Ok, thanks very much

@rjhow could you please check your php setting for “post_max_size”. It might have the default value of 8MB. But the plugin is actually bigger. So the upload might be rejected by your server.

Hi, I changed the limit and am now seeing a different error message:

ERROR Piwik\ExceptionHandler[2020-12-01 14:50:56 UTC] [8297a] Uncaught exception: C:\inetpub\wwwroot\matomo\plugins\CorePluginsAdmin\Controller.php(130): Something went wrong during the plugin file upload. Please try again.
ERROR Piwik\ExceptionHandler[2020-12-01 14:50:56 UTC] [8297a] Something went wrong during the plugin file upload. Please try again.

You could try to check the error code that is returned by the upload. Add something like var_dump($_FILES['pluginZip']['error']);exit; in plugins\CorePluginsAdmin\Controller.php line 130 (before the throw). Or append the error code to the exception message.
It can have one of the values mentioned here: https://www.php.net/manual/de/features.file-upload.errors.php
Maybe that helps to identify the reason

Hi, I added that line (hopefully correctly!) and have this error in the log now:

ERROR Piwik\ExceptionHandler[2020-12-02 11:50:10 UTC] [a3b3e] Uncaught exception: C:\inetpub\wwwroot\matomo\plugins\CorePluginsAdmin\Controller.php(113): Could not verify the security token on this form.
ERROR Piwik\ExceptionHandler[2020-12-02 11:50:10 UTC] [a3b3e] Could not verify the security token on this form.

Hi, i had the same issue and im a linux noob. Installing cURL solved my problem.

sudo apt-get install php-curl
sudo systemctl restart apache2.service