Warning: : failed to open stream: Invalid argument in D:\Websites\piwikDev\core\Loader.php


#1

I received the following error when I tried to test out my first plugin. The plug in works find in Piwik 2.2.2, before I upgraded to 2.3.0.

There is an error. Please report the message (Piwik 2.3.0) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Warning: : failed to open stream: Invalid argument in D:\Websites\piwikDev\core\Loader.php on line 98

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [D:\Websites\piwikDev\core\Loader.php:98]
#1 Piwik\Loader::tryToLoadClass(…) called at [D:\Websites\piwikDev\core\Loader.php:98]
#2 Piwik\Loader::tryToLoadClass(…) called at [D:\Websites\piwikDev\core\Loader.php:86]
#3 Piwik\Loader::loadClass(…) called at [D:\Websites\piwikDev\core\DataTable\Renderer.php:202]
#4 Piwik\DataTable\Renderer::factory(…) called at [D:\Websites\piwikDev\core\API\ResponseBuilder.php:95]
#5 Piwik\API\ResponseBuilder->getResponseException(…) called at [D:\Websites\piwikDev\core\API\Request.php:219]
#6 Piwik\API\Request->process(…) called at [D:\Websites\piwikDev\plugins\API\Controller.php:31]
#7 Piwik\Plugins\API\Controller->index(…) called at [:]
#8 call_user_func_array(…) called at [D:\Websites\piwikDev\core\FrontController.php:500]
#9 Piwik\FrontController->doDispatch(…) called at [D:\Websites\piwikDev\core\FrontController.php:85]
#10 Piwik\FrontController->dispatch(…) called at [D:\Websites\piwikDev\core\dispatch.php:34]
#11 require_once(…) called at [D:\Websites\piwikDev\index.php:47]

Fatal error: require_once(): Failed opening required ‘D:\Websites\piwikDev/core/DataTable/Renderer/Xml.php’ (include_path=‘D:\Websites\piwikDev\vendor/phpunit/php-token-stream;D:\Websites\piwikDev\vendor/phpunit/php-text-template;D:\Websites\piwikDev\vendor/phpunit/phpunit-mock-objects;D:\Websites\piwikDev\vendor/phpunit/php-timer;D:\Websites\piwikDev\vendor/phpunit/php-file-iterator;D:\Websites\piwikDev\vendor/phpunit/php-code-coverage;D:\Websites\piwikDev\vendor/phpunit/phpunit;D:\Websites\piwikDev\vendor/symfony/yaml;.;C:\php\pear’) in D:\Websites\piwikDev\core\Loader.php on line 98

Thank you for your time,

Louis


(Matthieu Aubry) #2

Does the file D:\Websites\piwikDev/core/DataTable/Renderer/Xml.php exist? it looks like php cannot read it somehow


#3

Thank you for your help. I tried again this morning and now everything works fine. Not sure what happend.

Have a great day,

Louis