Voir Admin sur Stats


(Moi) #1

Bonjour à tous;

AVANT, j’utilisais PIWIK, et, tout était OK…

Sur mon nouveau site, j’ai voulu installer MATOMO…

Bien, mais…

Pas moyen de me voir connecté sur mes divers sites …

IP ADMIN EXCLUE de facto par Matomo…

AVANT, ceci me permettait de voir si mon code d’intégration était correctement installé et, si, le suivi se faisait normalement…

MAINTENANT, je suis OBLIGÉ de passer par des PC “tiers”… Amis, famille, etc… pour savoir si, ça marche … ou pas !!!

COMMENT FAIRE pour

supprimer cette restriction à sa PROPRE IP et, se voir sur les TESTS…

Merci d’avance à tous pour vos renseignements…


#2

Je penses pas que ce soit par IP, mais par cookies…

Va sur l’admin de Matomo, dans Personal (mon Matomo est en anglais) click sur settings mais j’ai fais des imprime- ecran

ensuite descents tout en bas de la page et click pour enlever les cookies de matomo si tu veux que tes stats comptabilisent tes visites

EDIT: Je viens de decouvrir que tu peux aussi exclure des IP (dans Websites / Settings)


Regardes si ton IP est dans la liste, si oui enleves la


(Moi) #3

Merci Patrice, mais, ces paramètres sont déjà en ce sens…

Pas moyen de “me voir”…

En revanche, quand je passe par mon téléphone portable; le traçage est OK…
Pas très pratique…

Bizarre ce truc…

Merci encore pour ta réponse…
J’vais tenter d’autres trucs… mais, lesquels ???..
J’en ai déjà éclusé pas mal…
Bonne journée.


#4

Bonjour

Sinon tu n’aurais pas UBlock ou protection du même genre dans ton navigateur qui empêche la comptabilisation de tes visites ?


#5

Ah oui, tres interressante ta remarque!
Du coup je viens de tester et de decouvrir que Ublock Origin bloque matomo qui est sur mon propre site.

Avec Ublock actif Matomo ne voit que le code de l’image pour les navigateur qui n’utilisent pas Javascript

@circuit as-tu essaye de desactiver tes add bloqueurs ?
Aussi as-tu installe le code pour les navigateurs non javascript (pour etre detecte par Matomo si ton add bloqueurs est en marche)

(desole pour les accents, j’en ais pas sur mon clavier)


(Moi) #6

Bonjour à tous;

Merci pour vos réponses, mais ça ne vient pas d’un bloqueur de Pub - Ad-Block, U block ou autre.

Sur Opéra, effectivement, ils sont installés, mais mes sites sont en liste blanche.

Pour en avoir le cœur net, j’ai fait l’essai sur un Firefox tout neuf >>> rien de mieux
Tentative avec Edge >>>> même résultat.

Et, comme je suis vicieux, je me suis installé un Safari tout vierge…

ET bien, rien de plus…

Franchement je commence à désespérer.

Merci pour vos réponses, et bonne soirée.


(Moi) #7

Petite précision, j’ai AUSSI testé le script " sans java script "…

Résultat >>> pareil.

Et ce, quelque soit l’emplacement du script
En " Head "ou en " Footer "…

Rien n’y fait

Serait-ce mon site :

Qui est fait sous WordPress qui bug par une mauvaise config en Admin de WordPress ???

Je n’y comprends plus rien.


#8

WordPress… on commence peut etre a cerner le probleme :wink:

Je ne connais rien a WordPress, mais il y a surement dans l’admin du site WP ton IP pour que WP ne la considere pas comme une visite, si en plus Matomo est un module qui est gere par WP (comme j’ai pu le lire je ne sais plus ou) c’est sur que ton WP va lui passer ton IP pour que Matomo ne l’enregistre pas comme visite.

Donc je pense qu’il faut que tu cherches directement dans l’admin de WP a la place de regarder chez Matomo pour enlever ton IP(enfin je ne connais rien a WP mais ca me parait assez logique)
Mais il peut y avoir un contre-probleme en faisant cela: Un probleme de securite, par example si ton WP n’accepte que ton IP pour administrer ton WP c’est un plus, enlever cette possibilite va permettre a n’imporque qui de tenter de se logger en tant qu’admin en essayant de multiple combinaisons de mot de passe (a moins que tu es change le nom de la page d’admin dans ce cas il faut d’abord qu’ils trouvent la page…)

Bref je ne connais rien a WP mais je regarderais dans l’interface de l’admin de WP si mon IP est quelque part, ce qui repondrait a beaucoup de questions :wink:


(Moi) #9

@ Patrice…

Trop “space” ce truc…

J’essaie toutes les combinaisons possible sous WP…
Pas plus de résultat…

Vais tenter de réinstaller piwik2 et des coquilles ( je dois l’avoir encore en magasin ), et voir ce que ça donne.

Merci encore pour ton aide.

Bonne soirée.


#10

J’ai un site WordPress j’ai mis le code fourni par Matomo dans le pied de page et tout fonctionne mes visites sont reconnues je suis juste obligée de désactiver Ublock pour mon site.
J’ai regardé un peu partout dans mon administration WordPress mais je n’ai pas vu où il y aurait la possibilité de bloquer ou pas mon ip pour les visites.


(Moi) #11

@Maryl.

Bonjour et merci pour ta réponse, mais, comme je le dis sur des posts précédent…

Code en " Head " ou en " Footer " ( en tête ou en pied de page )… Aucune stat admin.

UBlock ou autres de ce même genre… NON ACTIF pour mon site.
Site mis en liste blanche PARTOUT…

Tests faits sur des navigateurs " VIERGES "… ( Aucun add-on mis dessus ).

Configuration WP vue, revue, et testée sous de multiples configurations… Rien à l’arrivée.

Avec Piwik 2, et quelque choses… Tout ALLAIT BIEN partout.

Dommage que lors de cette mise à jour vers 3 et des choses…
Cette version m’a tout planté, et n’ai plus accès à rien de mes anciennes stats de mes divers sites.

De plus pas moyen de réactiver correctement cette version 3 et des machins correctement sur mon site principal…

Bien les " AMÉLIORATIONS " … quand… ça marche…

P*^£^HT !!! Pourquoi ais-je tenté cette MISE à JOUR ??? :fearful::weary::rage::joy::face_with_symbols_over_mouth: