Visits disappeared from last visits graph


(DFTC Administrator) #1

we have been using piwik for 18 months or so with much success. we have been through several upgrades without major incidents.

within the last few weeks, we have had to report daily site visits to a few of our internal teams. on friday sometime, we checked our dashboard and we saw on the last visits graph that we had 300+ site visits. today, when we looked at our dashboard, our last visits graph showed no visits for last friday.

when i query the database, the piwik_log_visit table returns 448 rows for last friday.

i’ve read through a lot of the online content about visits not showing, but i couldn’t find any tips for troubleshooting this particular problem. if i have missed it, i apologize; but, any tips or guidance on how to troubleshoot this would be appreciated. even if someone can point me to the code used to execute the query that populates the last visits graph, that would allow me to do some deeper diagnostics on my data.

thanks in advance for your help.

piwik: 1.5.1


(Matthieu Aubry) #2

This is a recurrent problem which we are trying to fix for the next release.

When this happens, you can easily force piwik to re-process stats for given days: How to - Analytics Platform - Matomo

Also, we highly recommend to setup as explained: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo
as tis will help minimizing “zero visits” days


(DFTC Administrator) #3

Matt,

Thank you for the amazingly quick response! The recommendations worked like a champ!

Blessings,
Scott