Visitor Log and page title

(SxM) #1

Hi, how to have like the online demo on piwik the page title displayed also with the page url ?

Example1 is piwik demo

Example2 is my piwik, as you can see i don’t see page title for html files and also for php files

My piwik version is 1.2.1

Thank you

(Matthieu Aubry) #2

You can use the latest RC 301 Moved Permanently

(SxM) #3

Ok thank you so much, but why in piwik demo virtual drum doesn’t have page title in Visitor log ?

(Matthieu Aubry) #4

oops there was a bug in its javascript code (which was probably 3 years old) I fixed it on the site itself, not a piwik bug

(RonnyGey) #5

i have the same problem as SxM.
i want the visitor-log to
display the page_titles which link to the correct url, instead
of display the urls that link to correct url, by default.
i use piwik 1.2.1…
i played around with
but thats no solution, using setCustomUrl(“new_url”) to display “pretty urls title-like”…they are linking into nirvana…
i need to customize the visitor-log page to display the titles set by
and linked like always to the corret url…


(Matthieu Aubry) #6

Use latest RC (see blog post) to have this feature

(RonnyGey) #7

thanks, now it looks better…
i would like to see only the titles and the titles should link to the urls…
for better overview,…
is this configurable option?
would be nice if it would be so…maybe in future?

(RonnyGey) #8

“URLs sind sehr kryptisch, und ich möchte per javascript Title mitgeben,
die besser lesbare, aber NICHT existierende URLs darstellen!,
Piwik soll im VisitorLog pageTitles anzeigen, die zur url linken”

ich nutzt nicht
da die URLs nicht funktionieren…
“DEU_DE_DE/worldwide/history/1992” sieht aus wie eine URL,
ist aber keine in unserem System existente URL, sondern reiner TitleText


first make a copy of this file!

row 143: inhalt des links, statt $action.url soll nun $action.pageTitle verwendet werden
wer mag kann in selber zeile das margin-left anpassen


row 133 bis 136: nicht verlinkter $action.pageTitle über dem Link ausblenden
auskommentiert per

template-cache leeren, nicht vergessen