Version 2.14.1 (maybe already earlier) & Script for archive ignores parameter --url


#1

Hello,

I have updated from version 2.12.1 to 2.14.1.
Since then the archiving via the script piwik/console seams to ignore the parameter --url or is inconsequent.

In my instance I use two servers.
The first server is the primary delivery, archiving and database system.
The second server is the failover-system.
The databases are working in a master-slave-replication.

To achieve easy failover-steps I have configured two FQDN for the system.
One is available only from extern and pointing to an external IP. This is the base url.
The second FQDN is an internal DNS-Record with an internal IP.

Before the update I used the internal FQDN for the parameter --url successfully.
But now the script tries to connect to the external FQDN (base url).

That is not good and I don’t understand why the behaviour has changed.
Can you please explain it to me?

In the User Guide (How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo) is said that I have to use the base url.
In the help-context of the script is a note that the parameter --url is deprecated.
Is the parameter --piwik-domain the new alternative?
Thats all a little bit confusing.

Can I change the base url to the internal FQDN?
Is it realized when I switch the sequence of the Trusted Hosts in the config?

Best regards


(Matthieu Aubry) #2

Hi there,

FYI the fact that --url is ignored is a bug, we will fix it in coming versions: URL parameter for core:archive console command is ignored · Issue #8316 · matomo-org/piwik · GitHub


#3

Ok.

Is the parameter --piwik-domain the new alternative?


(Matthieu Aubry) #4

The --url parameter has been restored in 2.14.2 - enjoy!


#5

Ah, thank you a lot.
So it does not have the status deprecated?
What is purpose of the parameter --piwik-domain?