Vendor/tedvim/jshrink


#1

Hallo zusammen
kann mir jemand hier bei helfen
danke schon einmal

/piwik/vendor/tedivm/jshrink/src/JShrink/Minifier.php(243): Warning - "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? - Matomo 3.8.0 - Please report this message in the Matomo forums: https://forum.matomo.org (please do a search first as it might have been reported already


(Lukas Winkler) #2

Hi,

Die Warnung tritt auf, weil JShrink (eine Library, die Matomo verwendet) nicht mit PHP 7.3 kompatibel ist. Es ist aber nur eine Warnung, dass der Code, so wie er geschrieben ist, nicht ideal ist, es beeinflusst nicht, wie die Library funktioniert.

Das Problem sollte bald behoben sein (vielleicht schon mit 3.8.1), aber es muss etwas getestet werden, da die es sonst Probleme für 5.x-Nutzer gibt.

Falls dich die Warnung wirklich nervt, kannst du auf 7.2 wechseln, damals hat PHP über dieses Problem noch nicht gewarnt.


Piwik/vendor/tedvim
#3

Vielen Dank Lukas das war das problem nun werden auch wieder alle Besucher angezeigt.