User Settings page and widgets not working after 1.8.3 update

I just updated to version 1.8.3 and now I have the problem described below. I’ve searched here on the forum but I was not able to find anything. If there’s any discussion about it already, it would be great to know.

Otherwise, can anyone shed a light on this?

Thanks for your attention

***** Symptoms

When I access standard home page with dashboard the “Visitor browsers” widget does not show anything apart from its name, and the message “loading widget, please wait” (I’m translating UI from Italian, actual english message could be a little different).

For a short time I can see the orange error message from Ajax loading gone wrong (“Ooops, there was an error during request etc.” ).

If I try to add a widget from the user settings family, from the preview it looks like no one of them works, and I cannot add any of them back to the page if I have deleted it.

If I browse to page Visitor\User Settings at following URL:


it behaves like the widget: no data shown, orange Ajax error message for a while, and the “loading data…” message that never goes away.

I looked in windows events, under Windows logs\Application (again, please bear with me, I’m translating UI from Italian), and apparently everytime I refresh the page there’s an error in php-cgi.exe, caused by module php5.dll, exception code 0xc0000005 (which I think is related to bad memory access).
Then two consecutives AppCrashes for php-cgi.exe are logged.

***** System configuration:

I updated from 1.8.2 to 1.8.3. I did it by erasing previous site contents (I have source control anyway), putting on the new version contents, then adding my backed-up config.ini.php, then of course I followed the web install, which apparently went fine.

This is a development install.
Windows 7 64 bit,
IIS v7.5.7600,
PHP Version => 5.3.10,
MySQL Server version: 5.5.27 MySQL Community Server (GPL)

Adding some more details after further investigation:

For the Visitors Browser widget on the dashboard, the Ajax call causing the error has URL:


The error page returned from IIS it’s a 500 internal server error. Further info on the error page (translated from Italian):

C:\Program Files (x86)\PHP\v5.3\php-cgi.exe - The FastCGI process exited unexpectedly

Check the web server error logs for the reason that caused the error 500 ?

thanks for your quick reply.

I went through the Event Viewer, as a mean to check for those web server error logs. Here:

Control Panel->Administrative tools->Computer Management->Event Viewer->Application

The files in C:\Windows\System32\LogFiles\HTTPERR does not seem really helpful in this case.

When you say “web server error logs” do you mean something else, with more details?



now I’m looking at logs in C:\inetpub\logs\LogFiles. Probably you meant those ones.

I’m also following directions suggested in this article: IIS 500 errors leave clues in the log.

Looking at logs helped, but even more helped activating tracing for failed requests (those in FailedReqLogFiles).

Error details:




Internal Server Error 





The extended attributes are inconsistent. (0xff)

Although it seems there’s no sure way to find the root cause. Again, this is a development machine, running Windows 7 64. Not sure if this is a supported scenario.

in php.ini file, enable the error logging mechanis, and check the PHP Error being logged in your webserver error log file ?