Upload_tmp_dir is disabled, or is set to a common world-writable directory

This is a very common post based on Piwik’s security plugin but most of the responses are limited to the same possible solution. I set my php.ini for the following. (I also use user.ini but these are not set there).

open_basedir /home/userid/public_html:/tmp (for security I’m using userid here)
upload_tmp_dir /tmp

These settings were verified with phpinfo().

I’ve tried setting the tmp directory file permissions to 700 but I still get the same message in the Piwik security.

Is there something else I need to look at?