Upgraded to 1.2.1, UI broke and no solution found in forum


#1

Hi there,
Thanks for making this great tool. It really helps. Unfortunately things were going great and I saw your update message in my panel. I run it and see ok UI is there etc. Next day the UI wont load. It will show me the loding thing when I click on tabs but no data loads.

I turn on jslint in firebug I get following errors

jQuery(…) called incorrectly

and followed by

f is undefined
[Break On This Error] (function(a,b){function cg(a){return d…a+“px”)}}),a.jQuery=a.$=d})(window)

This happens each time I click on a report. The jqquery called incorrectly just keeps scrolling.

please help if you can
I checked the http://dev.piwik.org/trac/changeset/4135 but adding the line did not help me.

I know this is free software and support is free so not asking for much. just whatever is possible.

thank you devs and mates.


(Matthieu Aubry) #2

Delete your browser cache, and delete files in piwik/tmp/assets and try again?


#3

If anyone else is wondering as to the outcome of this solution, I had the same problem and matt’s suggestion worked perfectly, cheers!


#4

hi,
sorry for my delayed response. I was travelling.

Apparently it was just a firefox+firebug issue. When I use in Chrome it worked fine.

@matt Idid not try your solution but I keep it bookmarked in case this happens again. Thanks for your reply.