Upgrade to 3.0.0 fails with "To run Piwik you need at least PHP version 5.5.9"


Automatic upgrade to Piwik 3.0.0 caused "To run Piwik you need at least PHP version 5.5.9
Unfortunately it seems your webserver is using PHP version 5.4.13. " error :

I’ve tried to switch PHP to 5.6, but my hosting have an issue at the moment. I’ll try again once they allow me to use PHP 5.6. Meantime"Back to Piwik" and “Go to Piwik” links lead to the same page with the error message above.

Any ideas?


As it figured out ‘.htaccess’ file under the ‘public_html’ directory with code

AddHandler application/x-httpd-php-5.3.8 .php

prevented PHP upgrade. The actual upgrade in CPanel showed no problems, so this caused the confusion.

The bottom line: you must have PHP 5.5.9 or higher to use Piwik 3.0