Upgraded from V2.17.0 to V3.0.

Database update failed in browser (timed out)

Manually ran the SQL statements from command line. (completed)

Piwik still reporting that the database needs updating:

“Piwik database will be upgraded from version 2.17.0 to the new version 3.0.0.”

i have manually checked the DB tables and they have the new columns and column types.

Please let me know how i can either downgrade back to 2.17.0, or fix the issue with V3.0

Many thanks for your time.


today i received the email regarding the new update to V3.0.1

i followed the link in the email and got the message:

“upgrade from V3.0.0 to 3.0.1”

i ran the console core:update and it said a database update was required

i followed the procedure, but piwik is still saying the database needs to be updated and giving me the same SQL statements to run as before

is there a way to manually tell piwik that the database is already updated?

for example, is there a flag in the database options table which i can set/change?

how exactly does piwik determine whether the database is updated to the correct schema/version?

i really need to get this sorted as, obviously, no tracking has been happening since i ran the original 3.0.0. update

any response is appreciated

It sounds like a bug, because if you run core:update command and it finishes, then Piwik should be updated for sure. Could you please create bug report on our tracker and also paste the full message and SQL queries you get? Issues · piwik/piwik · GitHub

hi matthieu

thanks for the response

i will post it later as i am not currently on my development machine