Upgrade 1.2 -> 1.2.1 error - Please delete this post


#1

Something went wrong during automatic upgrade. But only after posting this I noticed I am not alone. This has alreadty been answered.

Moderators, please delete this.

Reporting as told here:

There is an error. Please report the message and full backtrace in the Piwik forums.

Notice: Undefined property: Piwik_CoreUpdater_Controller::$pathRootExtractedPiwik in /var/www/tilastot.xxxyyy.com/plugins/CoreUpdater/Controller.php on line 99

Backtrace -->
#0 Piwik_ErrorHandler(8, Undefined property: Piwik_CoreUpdater_Controller::$pathRootExtractedPiwik, /var/www/tilastot.xxxyyy.com/plugins/CoreUpdater/Controller.php, 99, Array ()) called at [/var/www/tilastot.xxxyyy.com/plugins/CoreUpdater/Controller.php:99]#1 Piwik_CoreUpdater_Controller->oneClick_Unpack() called at [/var/www/tilastot.xxxyyy.com/plugins/CoreUpdater/Controller.php:63]#2 Piwik_CoreUpdater_Controller->oneClickUpdate()#3 call_user_func_array(Array ([0] => Piwik_CoreUpdater_Controller Object ([] => ,[] => Array (),[] => Array (),[] => Array (),[] => CoreUpdater,[] => ,[] => ,[] => 0,[] => Piwik_Site Object ([] => 0),[newVersion] => 1.2.1,[pathPiwikZip] => /var/www/tilastot.xxxyyy.com/tmp/latest/latest.zip),[1] => oneClickUpdate), Array ()) called at [/var/www/tilastot.xxxyyy.com/core/FrontController.php:125]#4 Piwik_FrontController->dispatch() called at [/var/www/tilastot.xxxyyy.com/index.php:57]