Update vicious circle

I installed piwik from “latest.zip” and got v1.9.1. It worked, but the dashboard says to update to 1.9.2
The automatic method seems to work but the dashboard continues to say I have 1.9.1 and should update to 1.9.2
So I tried the CHMOD to 0777 on the piwik folder trick, but that simply gave me an Internal Server Error for my whole website.
So I followed instructions and backed up my config file, and went to download the latest version (helpfully called “latest.zip”) … but that’s the same zip file I started with, according to DuplicateFinderPro…


There seems to be a problem with the current latest.zip - you are right, that it contains 1.9.1 (core/Version.php). Wait for the problem to get fixed.

Problem is, that Piwik requests the version from a different source and when you click “Update” it downloads the latest.zip (and basically replaces your 1.9.1 with 1.9.1 from the latest.zip).

Vielen Dank!

Thanks for the report the bug was fixed, please try again!

Success! Thanks.