Update to 3.8.0 Problems


#1

Hello,

on two independent installations at two different hosters I got the same problem while upgrading to 3.8.0

SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘1074236db33.piwik_brute_force_log’ doesn’t exist

After doing it again and again at least I got Matomo working again and showing 3.8.0 as actual version. But the process was bumpy and faulty.

How to fix? Seems that the bug, known since b4 was not fixed.


Cannot sign in after update
#2

Yeah, I stumbled upon the same issue. Executing the update again, creates the new piwik_brute_force_log table. Console shows: Everything is already up to date.

I am not really sure wether the 3.8.0 update has been completed successfully, though? Do we have to apply additional changes manually? Do we need to restore from backup?


(Li-An) #3

Same message here. So I suppose the brute force protection won’t work.


(Fabian Dellwing) #4

After running the database update, everything should work fine. It seems like the application is trying to access the table before the database update happens. That’s why it’s throwing this error.


(Bjarne Oldrup) #5

Same issue here - screenshot attached.

After clicking “back to matomo” the Dashboard instructed me me that a database table update was needed, even though I’m pretty sure I read in the changelog, that an database updates was not needed.

After that bit bumpy experience, matamo 3.8 seems to be working - but I’d rather be without the error message.

Nevertheless - nice update! :smiley:


(Fabian Dellwing) #6

Don’t mix no major database upgrade with no database upgrade :wink:


(Bjarne Oldrup) #7

Whaaat? Do we really have to read EVERY word?! That sounds so inefficient! :wink:


(Jacek) #8

ok, I have this problem too. now I can not log into the system. How do I update the database now?
Can anyone help me?


(Marbot) #9

Just click on “Back to Matomo” at the bottom and you will be redirected to the page informing you about the database update to be done. There you click on the “Update Matomo” button at the bottom and you are done. At least this is what worked for me.


(Max Pinton) #10

This isn’t working for me for some reason. I was able to do the database update, but now I can’t log in. (“Error: Form security failed.”) I’ve deleted cookies. “console core:update” says “Everything is already up to date.”

Any ideas?


(Max Pinton) #11

I just tried it in a different browser and it worked, so I guess it was some kind of cookie/client-side storage issue (even though I cleared all that). Very strange, but resolved.


(Gert ) #12

Had the same issues (said error after the update, then couldn’t log in). Logging in on a different browser and clearing cache an cookies in my standard browser worked then.


(Korenisko) #13

Today I received some survey about self-hosted matomo and they asked about most pain or fear.
I wrote that MOST I fear when there is new update, because I lost matomo analytics data few years ago - when upgraded to next major.

Today - in the corner again…


(Ian) #14

Yes, I also got this error on both my installations. Doing the database update cured it…

… after a long wait when it looked like the whole thing was borked.

Was it too difficult to add a ‘if table doesn’t exist, create it’ line?


(Bjarne Oldrup) #15

Just some additional feedback. Todays update from a different matomo 3.7.0 site to 3.8.1 went smoothly here… No errors, database updated expected…

Nice work guys


(Lukas Winkler) #16

Matomo 3.8.1 was just relased which should fix the bugs reported here and a few more minor things (PHP 7.3 compatiblitly)

3.8.1 Milestone · GitHub