[update to 2.3.0] "All Websites" empty


#1

[size=small]Hello Community :slight_smile:

since the update to 2.3.0 the “All Websites” remains empty.

The data for each website is up to date. Sometimes the “All Websites” loads normally. Mostly not and is not reproduceable.

Ubuntu 12.04 LTS
Apache 2.2.22
PHP 5.3.10-1

While loading the “All Websites” it loads for 3-4 seconds and then shows only the total amounts of websites, visits, page-views…

up to now i tried the following:

  • mysql & apache2 restart
  • mysql.log shows no error
  • cleared browser-cache / on different browsers
  • changed template / using default template
  • renewed latest.zip
  • checked & re-set file-permissions in /tmp -R

Piwiks System-Check shows all green except Database abilities: LOAD DATA INFILE but that already was red before.

[size=x-small]Error:
Try #1: LOAD DATA INFILE : SQLSTATE[28000]: Invalid authorization specification: 1045 Access denied for user ‘piwik-user’@‘localhost’ (using password: YES)[28000],
Try #2: LOAD DATA LOCAL INFILE : SQLSTATE[42000]: Syntax error or access violation: 1148 The used command is not allowed with this MySQL version[42000][/size]

Tracking-Data is recieved for all Webpages. General behaviour is normal.

I hope i quoted all necessary details. Otherwise pls let me know and i will add…

Your help is much appreciated. Thank you![/size]


(Matthieu Aubry) #2

Can you setup the archive cron as explained in: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo ?
I think this should make the All Websites dashboard load very fast