Update Matomo mobile

Hi there …

Since the last update Matomo Mobile for Android is not able to connect any more (see picture).
I didn’t change anything and webaccess works well.

Any idea?
Regards, Hendrik


Is the Matomo server using a proper SSL certificate or a selfsigned one?

Can you check with SSL Server Test (Powered by Qualys SSL Labs) that the SSL config is correct.

Should be a proper one


I got confused as the domain is working for me in the browser, but I get the same error in the app.

But the solution is just below your screenshot:

Your SSL cert is signed by a GeoTrust certfificate that itself is signed by a DigiCert root certificate. The latter is a root certfificate, the browser trusts, but the browser doesn’t know anything about the intermediate certficate.

So for a properly working TLS connection, you need to set up your webserver to not only send your certficate, but also the whole certificate chain so that the browser can know about it.

Using a synology diskstation I didn’t find a way to tell the webserver to send the whole certificate.

Just changed to a “Let’s encrypt”-certificate …

Let’s see, if it works …

Regards, Hendrik


If you are using Let’s encrypt this is just a matter of using fullchain.pem instead of chain.pem.

Ok … just installed a new geotrust certificate … now it works:

Thanks for your help


1 Like