Update from1.3 to 1.4 White screen


(Erward) #1

Hi,
please help me with getting a “white screen” after updating.
It is fortunatly possible to “downgrade” to 1.3 again.
What to do and how?
Many greetings
Georg


(JulienM) #2

Have you tried emptying tmp/assets and tmp/templates_c ?

Is there a javascript error ?

Could you post a screen shot of the problem ?


(Erward) #3

Thanks for the help, I empteyd the files but it was not successful.
There is no error shown like javascript, the screen does only show “white” with no error…


(JulienM) #4

Which browser (& version) do you use ?

Have you tried looking at your apache logs ?

Do you see Piwik’s logo at the top of the page ?

Did you manage to log-in ?


(Erward) #5

Hi Julien
Firefox 4.0.1
I am not fit in finding log files
After upgrade there is no Piwik logo
There is not asked for log in, normaly it is automatical…

Now I tried again after closing the browser with no success


(Erward) #6

#7

Hi,

I have the exact same problem.

I cleared the two folders but the screen remain white. Has anybody solved this issue?

I also tested “going back” to Piwik 1.3 and it worked.


(vipsoft) #8

Were you prompted for a database update?

If you went back to 1.3, please make sure you reverted your database. Updating to 1.4 makes changes to the database schema.

If any of you can provide ftp access, then we can take a look.


(Erward) #9

Hi,
thanks for the problem again,
I tried it sometimes more but the same…
How to check the database?


#10

Hi Anthon,

No I wasn’t. In previous updates I was prompted to do so, but this time when I called up the piwik directory in my browser I wasn’t.

So I don’t think any changes were made.

I’ll check regarding the FTP access.


(vipsoft) #11

Erward: from your mysql client (or phpmyadmin), use the DESCRIBE statement, e.g.,


DESCRIBE piwik_pdf;

DESCRIBE piwik_log_visit;

In 1.3, there’s no “format” column in piwik_pdf.

Similar in 1.3, the “location_ip” column in piwik_log_visit is “UNSIGNED INT” instead of “VARBINARY(16)”.


#12

What DB changes do I have to make. I would update the DB in phpmyadmin and see if the white screen disappears.


(vipsoft) #13

Iwik: we need to know what state your database is in. If you’re on 1.4, please refer to my earlier comment and also query the piwik_option table:


SELECT option_value FROM piwik_option WHERE option_name = 'version_core';

lwik/Erward: what versions of PHP are you running?


(Erward) #14

Hi Anthon,
thanks for asking:
phpMyAdmin - 2.11.11.3 (is this the versions number?)
Many greetings
Georg


(vipsoft) #15

Erward: nope. You can get it by looking at the output of phpinfo(). It might be helpful if you PM the output to me.


<?php phpinfo();


#16

@ Anthon

Thanks for your quick responses! I’m still on 1.3 and I don’t get prompted to update the DB? Is there a way to update it manually?

My php Version is 5.2.0-8+etch16 (Zend: 2.2.0)


(vipsoft) #17

lwik: on your server, download latest.zip, and unzip the package so it overwrites your existing piwik installation, e.g.,


# this should be the directory above the piwik folder
cd /path/to/piwik/..

wget "http://piwik.org/latest.zip"

unzip latest.zip

Or download latest.zip to your desktop, unzip it there, and ftp the files over so that it overwrites your existing piwik installation.

If you’re paranoid about proxies caching an old version of latest.zip, then confirm piwik/core/Version.php says ‘1.4’.

Then browse (or open) “index.php”. You should be prompted to update.


(Monica/Anton) #18

I have the same problem. Have over-written files, tried to do manual execution via phpMyAdmin…nada.

Please assist.


(Erward) #19

Hi Anthon,
after a while of searching for:
PHP Version 5.2.14
Many greetings
Georg


#20

Hi Anthon,

thanks now it’s working.

Although I had the Filezilla settings on automatic it seems as if there was an errot. After uploading them in binary mode and calling up …/piwik/index.php I was prompted to update and everything is working.

:slight_smile: