Update Error


#1

Moin,

ich kann schon seit mehreren Updates nicht mehr automatisch auf die neueste Piwik-Version updaten. Zur Zeit nutze ich Version 2.8.0, aktuell ist 2.10.0.

Das Problem trat vermutlich auf, seit ich seit Oktober 2014 ein SSL-Zertifikat in mein Foodblog eingebunden habe.

Ich bekomme die folgende Fehlermeldung:

A fatal error occurred
The following error just broke Piwik (v2.8.0):
Class ‘Piwik\Decompress\PclZip’ not found
in /mnt/webi/e3/71/53358571/htdocs/nudelheissundhos/analytics/core/Unzip.php line 45

Ich wünsche Euch noch ein schönes Wochenende.

Grüße

Thobie


(Stefan Giehl) #2

Das einfachste wird sein wenn du die Dateien einfach manuell hochlädst.
Vorher die config.ini.php sichern. piwik dateien komplett löschen. neues Piwik im selben Verzeichnis hochladen. Config file wieder rein und dann aufrufen.
Dann solltest du im Update-Prozess landen und danach sollte es beim nächsten Update wieder tun.


#3

Moin, Steve,

ich habe Bedenken, dass ich beim manuellen Updaten irgend welche Dateien oder sonstiges “zerschieße”. Deswegen habe ich das bisher noch nicht manuell gemacht.

Die Frage ist aber, warum hat bisher das automatische Updaten funktioniert, nun aber nicht mehr?

Ich wünsche Dir noch einen schönen Abend.

Grüße

Thobie


(Stefan Giehl) #4

Solange du an der Datenbank nichts änderst kann dabei eigentlich nichts kaputtgehen.

Möglicherweise ist beim letzten Update etwas schiefgelaufen und manche Dateien konnten nicht korrekt angelegt werden.


#5

Moin, Steve,

danke, ich habe es jetzt so gemacht, wie Du es beschrieben hast. –> “Ihre Version 2.10.0 ist aktuell.”

Ich wünsche Dir noch einen schönen Abend.

Grüße

Thobie