Unusually slow response - on a nearly empty database


(TMG) #1

Hello,

I just installed piwik 0.5.5 on a local development server to try it out.

Specs:
XAMPP on a windows XP machine
MySQL 5.1.33-community
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i
PHP 5.2.9

No issues during installation (I selected mysqli instead of PDO; otherwise standard install). There is basically no traffic data for the site since it’s a development server (< 10 hits from me clicking around to test it).

But the app takes forever to do anything! Clicking dashboard and the widgets or pages load over the course of minutes. I mean, I clicked it before writing this forum post and it still hasn’t loaded. It eventually does load, but what do I have setup incorrectly here? The same system/db, etc. handles tables with hundreds of thousands of rows no problem. The demo on piwik.org works fine for me.

I tried truncating the archive tables, but it did not improve things. This occurs in firefox / IE / chrome. I have one website set up on it (http : // localhost/mydevdir). I put the standard JS tracking into two php files.

I don’t think the archiving / cron route is a reasonable thing to consider speeding things up since it crawls when there is no data to load! Any help would be greatly appreciated - I would really like to get this working and get away from GA.

Thanks a bunch in advance.


(Gus) #2

Hi,

Try with Piwik 0.6-rc1 : forum.piwik.org/index.php?showtopic=7761

style_emoticons/<#EMO_DIR#>/wink.gif


(TMG) #3

Thanks for the suggestion. I did a clean install of 0.6rc1.

It did not fix the problem. This time I installed with PDO_MySQL, so it’s not that either.

This is very frustrating. Anyone out there from Piwik Land know how to fix this?

I’d really like to use this but it’s failing miserably.

Any help is greatly appreciated.


(TMG) #4

Anyone? Does anyone moderate this forum? Is anyone there at all? Echo.

(echo)

It feels like a ghost town.

(…eerie silence follows…)


(vipsoft) #5

This hasn’t been reported by anyone else, so it might be a new problem.

Can you create a bootstrap.php file containing:

<?php
define('PIWIK_ENABLE_SESSION_START', 0);

(Johnny) #6

i have the same problem

i get some data. but pictures are broken, and says loading constantly

i have to logout and back on for it to display anything at all

im using same xampp setup and using google chrome for browser
IE doesn’t display anything just dumps to error

i can see the online demo just fine but on my install nothing

anything i can do to test or send feedback with debug info so this problem can be fixed.

how do i use the bootstrap.php file
i did the bootstrap.php file, and see it uses it in index.php
but nothing changed at all

really would like to get this fixed

used to use old phpvisits


(Johnny) #7

figured it out…

i forgot i never did try and figure out why but xampp does not like .htaccess files
i renamed them all to 1.htaccess and it works fine now. it was giving a 500 error(always has with xampp too) in some cases it displayed some it did not.

it works now.

i did upgrade to 06.rc1 works great

there are a lot of htaccess files under most of the sub dir one level down from piwik structure.

hope this helps someone and ill see about why xampp dont like them sometime

may want to pout a note in the docs for this or a sticky problem solver for others that come across this.


(Matthieu Aubry) #8

I use xampp and htaccess are not a problem for me, but maybe with your specific xampp or setup.


(JMan) #9

I’m having the same issue, I tried to rename the .htaccess files, but that did not help. I’m still trying to figure out why it is doing this. If I debug the project in (netbeans), it runs fine. but as soon as I try to hit the site outside of netbeans it’s doing the samething, “timing out”.


(JMan) #10

Ok, after digging around, it “appeared”(from a gut feel) that php was in some sort or “wait” state, like a “breakpoint” was hit. So I started digging around with xdebug and commenting out xdebug settings in my php.ini file one by one. Once I commented out this one:

;xdebug.remote_autostart=1

It started to work properly.

In case anyone else runs in to this and the .htaccess solution doesn’t seem to help, check that setting.