Unknown cron error


#1

Hello.

I have a problem for some time (earlier less, now on every running time)

START
Starting Piwik reports archiving…
ERROR: Got invalid response from API request: http://stat.krolnet.pl/index.php?module=API&method=API.get&idSite=2&period=day&date=last2&format=php&token_auth=bd9cd29907892dd79a61e514d98fe6c3&trigger=archivephp. The response was empty. This usually means a server error. This solution to this error is generally to increase the value of ‘memory_limit’ in your php.ini file. Please check your Web server Error Log file for more details.
WARNING: Empty or invalid response ‘’ for website id 2, Time elapsed: 0.651s, skipping

memory_limit is set to 1 GB, display_errors is on.

When I run this url in browser - after few seconds (3 - 5) I get a json response with lots of numbers.

When I run this script manually - all works fine.

INFO [2014-04-24 14:47:02] [2e11d] START
INFO [2014-04-24 14:47:02] [2e11d] Starting Piwik reports archiving…
INFO [2014-04-24 14:47:05] [2e11d] Archived website id = 2, period = day, 1960 visits in last 52 days, 70 visits today, Time elapsed: 3.577s

Cron’s entry:

0 */2 * * * /usr/local/bin/php /home/daniel/domains/stat.krolnet.pl/public_html/misc/cron/archive.php --url=http://stat.krolnet.pl > /dev/null

What am I doing wrong?


(Matthieu Aubry) #2

When you get this error, check your web server error logs for more information?


#3

There are no errors in logs. When I run it manually all works fine, only with cron there are a trouble…