Unable to get Piwik to work with https://


#1

Hi, I just installed Piwik but got stuck on something. I installed Piwik using Softaculous on cPanel. I first installed it choosing the option “http://”, but then decided after reading the FAQ that I’d like to use SSL, so I added “force_ssl=1” to config.ini, but then if I went to https://“mysite”/piwik I just get a “404 not found” error. I then deinstalled Piwik and reinstalled choosing the option “https//” when asked in Softaculous. I still get a 404 error.

Is there something obvious I’m doing wrong? The site I’m using it with, which is installed using wordpress, doesn’t actually use https://, does this have something to do with it? Thanks for any help!


#2

Is https://yoursite/ accessible?
Dit you check with FTP to see if there is actually something installed in yoursite/piwik?


#3

I can see Piwik installed and it even gives me a login screen at http://mysite/piwik (unencrypted), but won’t let me log in there. (https://mysite/piwik just gives a 404 error)

https://mysite doesn’t work right - it just brings up a placeholder page. This makes me think that https:// is disabled overall and there’s some setting or code I need to change, but I haven’t figured out what.


#4

Sounds like you need to check the settings in your hosting account. You probally need to buy and install a SSL-certificate, or maybe you can use a shared one if your webhost offers one. Or maybe you just need to set a symbolic link from private_html to public_html so the server knows to serve the same content for both http as https.

Drop your webhost a line, they can what’s wrong and fix it for you.


#5

Thank you for your help! I hadn’t bothered set up SSL since there are no visitor logins or forms on my site. There’s an SSL/TLS tab in cPanel which, among other options, will allow me to set up a self-signed certificate which would probably be sufficient for my own needs since I’m just logging in for admin purposes. If that doesn’t work then I’ll ask the host account for help.