Unable to configure piwik

I get the standard error during install…

Piwik requires either the mysqli extension or both the PDO and pdo_mysql extensions.

On a Linux server you can compile php with the following options:

Here is the configuration from my system…

[root@xxxxxrf html]uname -a
Linux xxxxxrf 2.6.18-194.el5 #1 SMP Mon Mar 29 22:10:29 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

[root@xxxxxrf html]# cat test.php

<?php $extensions = @get_loaded_extensions(); if (in_array('mysqli', $extensions) && function_exists('mysqli_set_charset')) { echo "MySQLi is supported\n"; } if (in_array('PDO', $extensions) && in_array('pdo_mysql', $extensions)) { echo "PDO MySQL is supported\n"; } [root@xxxxxrf html]# php test.php MySQLi is supported PDO MySQL is supported [root@xxxxxrf html]# php -i | grep mysql Configure Command => './configure' '--with-mysqli' '--with-pdo-mysql' mysqli Client API library version => mysqlnd 5.0.10 - 20111026 - $Id: b0b3b15c693b7f6aeb3aa66b646fee339f175e39 $ mysqli.allow_local_infile => On => On mysqli.allow_persistent => On => On mysqli.default_host => no value => no value mysqli.default_port => 3306 => 3306 mysqli.default_pw => no value => no value mysqli.default_socket => no value => no value mysqli.default_user => no value => no value mysqli.max_links => Unlimited => Unlimited mysqli.max_persistent => Unlimited => Unlimited mysqli.reconnect => Off => Off mysqlnd mysqlnd => enabled Version => mysqlnd 5.0.10 - 20111026 - $Id: b0b3b15c693b7f6aeb3aa66b646fee339f175e39 $ Loaded plugins => mysqlnd,example,debug_trace,auth_plugin_mysql_native_password,auth_plugin_mysql_clear_password API Extensions => pdo_mysql,mysqli mysqlnd statistics => PDO drivers => sqlite, mysql pdo_mysql Client API version => mysqlnd 5.0.10 - 20111026 - $Id: b0b3b15c693b7f6aeb3aa66b646fee339f175e39 $ pdo_mysql.default_socket => /tmp/mysql.sock => /tmp/mysql.sock I am baffled as to why I am still getting the error when all the pre-requisites are in place. Any pointers will be greatly appreciated. thanks in advance. Kiran.

Make sure that the extensions are also enabled in your etc/php5/apache2/php.ini and not only your CLI php.ini ?

Here is the data from php.ini

extension=pdo.so
extension=pdo_mysql.so
extension=mysql.so
extension=mysqli.so

Kiran.

whichi php.ini ?