Unable to change logo


#1

When I try to change the logo of my piwik install I see an error about permissions on the logo folder path. I have checked the permissions and they are ok.

Has anyone else seen this issue at all?

Thanks in advance

Gary


(Matthieu Aubry) #2

Hi Gary I haven’t heard this issue before. Could you take a screenshot showing the error message?


#3

Sure. Attached.

The only changes are upgraded to latest Piwik and I removed an old user. That user was the one created during the install. I do however have my user who is a super user.


(Matthieu Aubry) #4

Are there files already in misc/user ? delete them if there are any logo file in there. Otherwise check the directory is really writable by the webserver user (eg. chmod 644 or 755 or 777 if else does not work)


#5

Hi,

I have removed the images and the issue is still there. I have also opened permissions to 0777 and checked the directory is owned by apache.

I still have the same issue?

Thanks


(Matthieu Aubry) #6

FYI here is the code: matomo/CustomLogo.php at master · matomo-org/matomo · GitHub

looking at the code now, I realise it also tests that file_uploads is set to 1 in the php.ini

can you check if yours is set to 1?Also we should probably improve the error message in this case


#7

My entry says

file_uploads = Off

Set it to 1

and problem solved :slight_smile:

Many thanks for the rapid responce Matt

Cheers

Gary


(Matthieu Aubry) #8

Good to hear! I’ve fixed this and piwik will now display useful message when this is the case: When file uploads is disabled, display a meaningful error message · Issue #5403 · matomo-org/matomo · GitHub