Unable to add new site


#1

I can not add new site. the page does not load interface. I also made a new installation but it does not work.
see image

thanks


#2

no one answers in this forum?


(Matthieu Aubry) #3

can you check in your server erorr log file if there is some error?

See also this faq which maybe will help: How do I configure my server to let Piwik serve HTML files? - Analytics Platform - Matomo


#4

Hi Matt, I use Piwik for 5 years, and I’ve never had any problems with installation / configuration. Although this installation worked fine until the latest updates. You can download the older version to test?

thanks


(Stefan Giehl) #5

Which browser are you using? If your browser is a bit older it might be possible that angularJS which piwik is using more and more breaks.
For Example: Opera 11.00 is not working anymore (while 11.64 still works)


#6

I do not think they are browsers, I have tried all, Chrome. Firefox, Explorer. If you look at picture, you see that the result is websites = 0 (indicated by arrow). Yet 1 is configured…


#7

what about trying to delete tmp folder contents and ensure the php.ini has sufficient memory. Maybe it was set to an old default when you upgraded?


#8

I do not know, I only see that it does not work


(Matthieu Aubry) #9

With your browser, open the developer tools, then look at REQUEST tab. Then see if the request returns an error when you load the “Websites” page. Maybe you see a red line or something else?

Also check your webserver error log after opening WEBSITES pages to check if there’s an error there.


#10

With Chrome Console have only this error:

Plugin file loaded index.php?module=Proxy&action=getCoreJs&cb=43f507349a3fc1a7e13d9b230c91306d:1629
Failed to load resource: the server responded with a status of 403 (Forbidden) http://www.xxx.it/stat/index.php?action=getGlobalSettings&date=last7&format=JSON&idSite=1&module=SitesManager&period=range


(Matthieu Aubry) #11

the server responded with a status of 403 (Forbidden) http://www.xxx.it

This is the problem! Can you ask your webhosting provider to investitage this 403 error?

And then can you let me know what caused it once your provider answered you (I will add it to this FAQ: How do I configure my server to let Piwik serve HTML files? - Analytics Platform - Matomo )


#12

Thanks Matt, ok I ask but it never happened. If I try to change some file permissions with FTP?


#13

Ok Matt, I attached errorlog of the last hours