Two-factor authentication is not working

If you are a super user yourself and are unable to log in, you can disable two-factor authentication through the command line

$ ./console twofactorauth:disable-2fa-for-user --login=yourlogin

I have an issue where to place this command as a super user. Is this Linux command and I can do using WHM panel?


For this you need some kind of way to execute PHP from a commandline. On windows this will probably look a bit more like

php.exe \the\path\to\matomo\console twofactorauth:disable-2fa-for-user --login=yourlogin

How to manage from root root access?

It works without any issue if I use Recovered keys. But using usual authentication it will not work. How to execute using Linux command
as you posted execute PHP from a commandline on Windows.

I have disabled Google Authenticator and enabled again. Numbers are not detected as it seems Matomo has any connection to the timestamp inside Google Authenticator. How to manage this as I see I have Github inside Google Authenticator. Is it Matomo inside this app or some settings prevent the same numbers Sync. Please reply if this is a bug inside Matomo.