Trying to import Google Analytics

I’ve been following steps on how to import Google Analytics into standalone Matomo

It is sooooooooo complicated omg!! In the end I couldn’t made it, I got an error “Could not verify the security token on this form.”
I have tried to redo some steps, but it seems that something is missing? After fiddling around I noticed that under “OAuth consent screen” there is some verification process we should also do (?). I am not sure, but I tried to do that. Now I can see the message there:
“The Trust and Safety team has received your form. They will reach out to you via your contact email if needed. The review process can take up to 4-6 weeks. Expect the first email from our Trust and Safety team within 3-5 days. Your last approved consent screen is still in use.”

Anyway, maybe you need to update that tutorial page?
To be honest, I wouldn’t even bother going through all that if I knew it was such a pain… I am trying to learn how to use Matomo but this part isn’t very promising. Is google doing this on purpose just to keep everyone locked in their system?


Unfortunately most of this complexity is on Googles site as you need all of these steps to create an API token to be able to access the Google Analytics data programmatically.
And to make things worse, these steps change every few months meaning that the guide might differ slightly from how Google shows the steps to you now.
That said it should work in general, did you get the Could not verify the security token on this form in Matomo or on the Google site?

If you know any way to simplify this, I’d be happy to hear it.

I’m having the same issue: An error occurred: Could not verify the security token on this form.
It happens right after this step:
Now, click Authorise and follow the prompts to give Matomo access to your Google Analytics data.

at this URL:

So to answer your last questions, it happens in Matomo. Any thoughts on the matter are highly appreciated.


After checking out this link, I decided to wait a while before clicking any button (and let everything load in the background?). This time it worked without the error message. I got the same error after clicking ‘Deactivate’ (the GA importer plugin) on the plugins page. And waiting a while before clicking solved this as well.