Translation broke flash?


#1

Hi all.

I was updating today Serbian translation for Piwik 1.1 and all of the sudden I was unable to see flash components of Piwik. Tables are displayed but no graphs and vidgets. Piwik says Displaying Graphs in Piwik requires Flash >= 10.0.0 but I have it installed, it worked this morning normally. Even don’t have drop down list to change display language I changed language for admin to en manually in mysql table piwik_user_language, language changed to English but still no flash.

Can it be that some broken translation string is cause of this?

I have Piwik 1.0 installed on other site (where I didn’t changed language files yet) and everything is displayed just fine so I assume it is not browser related problem.

Thanks in advance.


#2

No, PDFReports plugin broke it. I disabled plugin now and flash works again.


(Matthieu Aubry) #3

what browser were you using?


#4

Firefox 3.6.13 on Arch Linux. Today I updated Piwik to 1.1.1 and problem still persists: with PDFReports plugin enabled - no flash


(Stephen J. Fuhry) #5

PDFReports breaks javascript stuff for me too. Using firefox 3.6 on Ubuntu.


(Matthieu Aubry) #6

Do you see any Javascript error ? any other information that might be useful?

if you look on demo.piwik.org does it work? the PDF report is enabled there.


(Stephen J. Fuhry) #7

See attached screenshots. jQuery claims not to be loading on the later, but when I try to directly access the link provided in the source, the file loads just fine. Not sure what’s going on there.

If you would like to debug it some more, I can give you a login to the instance I have setup where this is happening… it doesn’t bother me though, I’ve never used that plugin before so disabling it is good enough for me.


(Matthieu Aubry) #8

Do you see the same error on demo.piwik.org ?

can you try and delete tmp/assets/* files and refresh (with PDF reports) to see if it was an out of date asset file?


(Stephen J. Fuhry) #9

rm -rf tmp/assets/* fixed it for me. Thanks!


#10

If I remove tmp/assets flash works. But, when I deactivate and activate PDF plugin again, it does not work again. I am too not using this PDF anyway…


(Stephen J. Fuhry) #11

Interesting… Disabling & re-enabling the PDF plugin breaks flash for me as well. No javascript errors this time though.